PathWeaver not working

Exactly as it sounds. It’s in tools in VScode but it doesn’t launch. I run it also doing ./gradlew PathWeaver but it builds instead. We tried it on a different PC and it only works if we don’t put the 2020 json in games.

Maybe your 2020 JSON is invalid. I would try one of two things:

  1. Delete your 2020 game info and update to WPILib 2020.2.2
  2. Delete your 2020 game info and try again with these steps: Pathweaver 2020 Game Help

Where would I find game info? On my computer path weaver doesn’t even have a folder under the %userthingy% directory.

If there is no PathWeaver folder under %userprofile%, then you can create the PathWeaver folder and the Games folder.

Tried that. Didn’t work. Same symptoms

Have you installed the WPILib installer? Instructions here:

I’ve done everything. I found all the tool .jars and tried to open them, nothing did. Also the other tools don’t open either.

What platform is this? If Windows, do the shortcuts on the desktop not work to run Shuffleboard et al? It seems like something on your system is causing Java programs not to run. Try running from the command line… is there any error message printed?

It was my java version. I could run it from power shell right after I checked the version: 13.blahblah. I go into VScode and it said something about this file is 55, too new! (you’re using 52). <this was after I tried from VScode and it crashed again.

If you ran the installer, the shortcuts / batch files should be running the programs with Java 11 (don’t run the jar directly). But make sure you don’t have Java 8 installed.

I ran the jar through powershell after making sure java -version was 13; and that’s the only way it worked. after running it vs code it crashed and java version said 1.8… are you suggesting I remove the other javajsdk1.8, java1.4, java 12.1 etc…? < java

Hi, I am a software mentor helping one of the programmers to set up his Windows 10 laptop for using PathWeaver. I see the same problem on his laptop, and the tool still does not work. So far here is what we tried:

  1. Uninstall and reinstall FRC 2020 Game Tools and WPILIB Installer.
  2. Set the environment valriables “Path” and “JAVA_HOME” for both user and system using Windows’ “Advanced settings…” menu.
  3. Tried to run PathWeaver from
    a) Start Tool → PathWeaver in FRC 2020 VScode
    b) cd C:\Users\Public\wpilib\2020\tools
    c) python .\
    d) java -jar .\PathWeaver.jar
    (a), (b), and (c) does not show any output or error message.
    (d) produces an error message and hangs. (message screenshot below)
  4. Tried to run ShuffleBoard from FRC Vscode, Driver Station, Desktop icon, and command prompt. Nothing happens in all cases, and no error message either.
  5. Driver Station works, we can build Robot code successfully from FRC VScode, and we can deploy default Dashboard from the Driver Station.

Is there anything we can try to get these tools working? I feel there may be some setting in his Windows 10 that is preventing them from starting, but I am not an expert in Windows internals. Thanks in advance for any help!

1 Like

What if you run with the wpilib jdk?

cd C:\Users\Public\wpilib\2020\tools
…\jdk\bin\java -jar .\PathWeaver.jar

1 Like

Same outcome as (3d) in my post above. The command hangs after printing an error message as shown in the screenshot.

You installed python, right?

Yes, we installed python. All the other laptops that I tested (2 windows and 1 Mac) are working as expected when we run these tools, so I think the issue is with this specific laptop/windows settings.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.