PCM Status Random

We just finished the wiring on our robot and the PCM status randomly turns from green to red without us touching the robot or the controllers. We are using 3 M5 solenoids.

We have tried 3 different PCM, we tested the power from the PDP and the wasn’t the problem, we tried it with one solenoid at a time and it seemed to work and then it randomly started to do it again, we tried programming and even copied our last years program to see if that was the problem and it wasn’t that.

Any Ideas on what it could be? would be greatly appreciated. Thanks!

Did you check the Status Light Quick Reference for the PCM? It might help.

So I’m guessing it could be a CAN issue or a solenoid fault.

It is a constant red light so what would that mean? Compressor fault? Or could that still mean that it is a CAN issue or Solenoid fault?

Use Tuner’s “Self Test” to find out.

This is what it shows with the robot disabled.

I think it says it right there: “Most likely the compressor output was shorted”.
But it’s a sticky fault which means it happened before but not right now (as the now column is 0).
That could be the reason for the red status.
Does the PCM red light occur only while the robot is enabled or the compressor is running?

When it’s enabled the light flashes red slowly. When it’s disabled it has an orange/amber colored light. Opinion?

We thought it was the compressor shorting out because when we switched that it stopped but now a couple hours later it started doing it again.

Is your pcm anywhere near your radio? It messes with the pcm and causes faults.

Wouldn’t have believed it myself until it happened to us last year. For reference :

We will have to try that out. Do you have any idea what kind of distance would be optimal for it to not interfere? Because we do not have very much room for electronics when we designed our build.

Thank You!

We rearranged to make them 18ish inches apart and never had another fault. That’s probably further than needed but we wanted to be completely sure.

If it occurs again we will comment again but that seems to be the problem thank you!!