PDP red/green rapid flash

,

1712’s PDP and all other motor controller indicator lights keep flashing in odd color patterns. The PDP is flashing red/green, like it is getting and then losing CAN rapidly. all of the motor controllers are doing this too. we have tried re-wiring the CAN, and it did not work. we turned off the resistor on the PDP, and attached the one at the end of the CANbus wire. now, the lights are giving the damaged hardware fault, and we don’t know why. we would prefer help soon, because our competition is this Saturday and we haven’t tested the code yet.

Tried different batteries? Do you have a second PDP to try? Consider contacting CTRE as well

Edit: in addition, check the firmware version and then re-update it anyways

To troubleshoot, I’d suggest you hook up only one CAN device to the roboRIO, e.g., the PDP or the PCM.
Disconnect all others to start with.
See if you can see them running Phoenix Tuner and check the device status through Tuner.

Issue has been solved. Not all the Spark Maxes had their CAN IDs set, so there were conflicts between the PDP and the Spark Max for CAN ID 0.

Seems like it shouldn’t have to be asked but I made this stupid mistake just a few hours ago:
Are you absolutely sure yellow is to yellow and green is to green?