Permission denied when pushing code

Our team is running into a few issues pushing code to the roboRIO so we thought we could post here to find help. When we try to ‘clean project’ an error occurs saying "Cannot run program “rm”: Launching failed.

When we try to deploy we get “Remote command failed with exit status 1.” There is also “Permission denied” printed on every other line in the console.

We can’t seem to solve these problems and any help would be greatly appreciated


Windows or Mac or Linux?

Have you set a password on your roboRIO for the admin account?

I see the Cannot run program “rm”: Launching failed message as well, on windows, but the project does get cleaned. I also asked about it in another thread.

Or the lvuser account.

Having this same problem on a freshly imaged roborio, with windows. Anybody have any ideas?

Can you please post the complete download log from the Eclipse window?

A few things I failed to mentioned.

  • We are using Windows 7
  • The roboRIO has a fresh 2016 image
  • This happens on all of the laptops we try to use

After trying a bunch of things, we managed to fix this by using PuTTY to SSH into the roboRIO. We then used the “cd” command to move to the home directory for lvuser and ran “chmod u+x /home/lvuser” which essentially gives write permissions to the owner of that directory.

This is a very weird way of solving the problem but it works and I am not sure why no one else got this issue

I just received this issue after updating (repeatedly) the firmware and image on our practice robot RoboRIO. I tried your fix but it did not seem to work. Please see below for a screenshot of the errors.

I know at least a few others on CD have reported similar to identical “permission denied” errors. I am not a hardcore programmer at all, so pretend I’m very unfamilar with Linux and SSH and all that jazz and please help me (and others) diagnose this problem quickly. Thanks in advance for the prompt assistance!

EDIT (twice…) - I was able to log in to the roboRIO using PuTTY and the admin login. I was also able to login using lvuser, but when I did, I got the same “permission denied” errors upon typing “lvuser” and pressing enter. See the other screenshot below.

Is there any chmod command or other such magic that can be employed against this impenetrable directory stronghold? Help me toss 8 boulders at this thing.

And please don’t tell me to reimage the roboRIO without giving me a valid reason why I should. I’ve done that already. :smiley:

2-26-16 PuTTY Output.jpg

2-26-16 PuTTY Output.jpg

Travis, you’ve modified the build files. In order for people to help, you’ll need to detail the changes you’ve made. My suggestion is to reimage and reinstall wpilib so the original build files are restored.

I initiated a reimage before you posted while I was waiting for someone to reply. :smiley:

How does one correctly uninstall/reinstall wpilib?

Is there anything I need to do to my project after wpilib is reinstalled? Remove files? Rebuild?

Speaking of wpilib, I was prompted to update the WPILib plugins in Eclipse today. Did they push a new release?

In eclipse, go to help->installation details and select Robot C++ Development (and Java if it’s also installed), and press uninstall. Then, for good measure, delete c:\users<user>\wpilib

Just a rebuild.
Last wpilib release was 2/11. I did see an eclipse update today.

Just a rebuild.
Last wpilib release was 2/11. I did see an eclipse update today.

Done, thanks. I have reinstalled wpilib and rebuilt my project, and I will go into the school shortly to try it out. Any ideas on what to do if the problem persists?

Also, any thoughts on how I might have altered the build configuration files? I did play around in there but only after the original problem popped up and I searched for threads on this problem on CD.

FYI, I did add very basic navX MXP stuff to the include and library settings early yesterday, before the issue, but I followed the instructions on their site. I will refrain from doing any of that until I can deploy code again. I’ll save the project and then play.

Just for fun, I got the roboRIO off our 2015 competition robot, updated the firmware and imaged it EXACTLY per the instructions (i.e. how I did everything before), and I’m still getting permission denied error. This time, however, it seems to proceed to the “kill all” part of the deploy routine before faulting. See attached, updated screenshot.

Please keep the suggestions coming - I’m at the school all day today and can try anything out quickly. Obviously, this is a problem that needs solving ASAP.

I just installed Eclipse et al on another laptop and used some old version of my code that worked prior to this problem, and the permission denied error occurred on deploy exactly as before.

Still hoping for some good ideas here from the community!

This popped for us today, any ideas?

I just got ours to work…but I don’t really know what I did.

I reflashed firmware and reimaged the roboRIO multiple times using our driver station Classmate and my programming laptop. No dice.

I swapped the roboRIO with another one - no dice. Same problem.

I got a completely different laptop, updated the WPI plugins, tried to deploy, no dice.

I used the same laptop to reflash and reimage the roboRIO. I deleted the project from the workspace, then reimported it and rebuilt. At this point, it downloaded. I am not even sure that action contributed to the fix.

Anyone experiencing problems, please cross-post details to the FIRST Forums thread here -

Time to make it loud. :slight_smile:

If you’re familiar with Linux, could you try ssh-ing to the roboRIO as lvuser and check the permissions and ownership of files in the lvuser home directory and look for anything not owned by lvuser. It seems like somehow something is getting messed up, maybe a a download failing part way through or something.

If not, I would expect that reimaging and being sure to check the reformat box in the imaging tool would get you back. If you do that, be sure to reinstall Java if that’s the language you’re using.


We SSH’d to the roborio as admin, then did

chmod -R 777 /home/lvuser/

To give all users read, write, and execute permissions to the folder.

lvuser was not the owner of the /home/lvuser/ folder, to we gave all permissions to everybody.

Its now working for us.