Permission to /home/lvuser/deploy

Today I tried to use PathPlanner and it failed to load the path file from the project’s deploy folder. The log said permission was denied to /home/lvuser/deploy. I was able to resolve it by ssh’ing to the roboRIO and granting permission.

Is this a known issue that I missed in the documentation? I remember seeing discussion about it during the 2023 beta, but this rio was up to date, and I don’t think it ever had the beta on it. The workaround isn’t hard, but it takes a little Linux knowhow and wouldn’t be obvious to many FRC programmers.

That directory is written to at deploy-time, so barring any other (manual) interactions, it should just work.

What permission did you have to grant? Just curious if it was an ownership issue, or if the files were somehow missing read permission.

GradleRio deploys the deploy folder as admin. Deploy folder deploys as admin · Issue #408 · wpilibsuite/GradleRIO · GitHub

I’m not familiar with PathPlanner, but if it isn’t deploying as admin, that could be the source of the problem.

Interesting. I haven’t tried anything else in the deploy folder this year, so I thought it was an image problem. But now that you mention it, I did push the “Deploy” button in PathPlanner at some point. I’m new to PathPlanner as well. It puts the paths into the robot project’s deploy folder, so they get copied with the robot program, but it also has its own deploy feature when connected to the robot. Maybe it’s a PathPlanner bug.

I just went nuclear with chmod 777. If I recall correctly, the owner of the deploy folder was admin but the owner of the other folders was lvuser.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.