Persistent "no robot controller found" error

We’ve had a sporadic error in the past few days. When we try to download any hex file to the robot with IFI Loader, we get the error “No robot contoller found,” with the IFI_Loader error window that reminds us to check power is on, cable connected, and Program State LED orange.

We have doubly checked all of these things, and we’ve confirmed IFI_Loader is using port COM1 (our only COM port). We reinstalled IFI_Loader and restarted. We have charged the blue RC backup battery. We are running v.1.1.0 of IFI_Loader.

We tried using our computer with last year’s RC, and we can verify the robot controller connection, which makes us think this may be an electronics problem?

We can’t even download the default code, which makes us think this wouldn’t be a programming error… We had this problem Saturday, and then things worked Monday, and then Tuesday the problem recurred.

Any ideas?

Are you running any other programs that might be using the serial port? I believe this is the error that is reported when ifi_loader is unable to open the serial port.

From one of the menu’s at the top select verify robot controller, or something to that effect, that fixed it for me at least.

Thank you for your reply. We usually have MPLab open. Would it have any reason to use the com port? We will try again tomorrow with IFI_Loader running with no other programs open.

I can’t think of anything that MPLAB might be using the com port for. I do know that I almost always have MPLAB open when I download to the RC.

Make sure that you have the modems on the right sides. I believe the one with the small black antenna should be connected to the RC, and the one with the silver antenna connected to the OI. We did that and spent quite some time troubleshooting before we realized what was going on. :rolleyes:

I don’t see what this has to do with programming it?

What are the LEDs on the RC doing? I had a problem like this, it seemed to be trapped in program mode and wouldn’t respond, booting just the master processor. Hold PROG and RESET for about 15 seconds, then release RESET. You should get a green power light, an orange program state light, and three dark LEDs. I may have reversed the procedure to release the buttons, if it doesn’t work, try releasing PROGRAM instead of RESET…

Our team had a similar problem like that. The controler seamed to be in program state and would not come out of it. Being a Mechanical guy, I did the only thing I know, dry run it. Unplug both batteries, all serial cords and turn the robot on and off several times. Hit the program and reset buttons a few times and then plug everything back in. What I am attempting to do here is clear out the loop in the controler making it think it is in program mode.

Disclaimer: I am a mechanical guy and know little of programing or code. All I know is this worked for us. I am sure someone will tell me that there are severalif not all steps that did not need to be done.

Might want to try uploading the master code again, see if that helps.

Whoops, that’s what i get for not really reading the thread properly… :o
I was thinking about the OI not found error (you know, it can communicate over tether but not over the wireless modems). My bad.

Thinking about that error… are you using the correct cable? Make sure it is one of the black ones used for programming and the radio, not the red tether. Also, not really sure if this will stop it from programming, but maybe make sure that your backup battery is fully charged/connected?

Thank you for so many tips!

We still haven’t had success getting the computer to see the RC.

We are using a black serial cable to download the program. We charged the RC backup battery overnight.

One of our mentors suggested disconnecting the batteries and leaving everything on for 24 hours. We’ll see if that helps…

I’m not a programmer, but have you tried using the tether (red or cream cable) at all?

MANY THANKS to everybody who posted suggestions! We tried all of them. Unfortunately, none worked. We posted the same question to the IFI Robotics support forum, which led to an email, which led to a 45 minute phone call with IFI. After a few tests/diagnostics with our 2005 and 2006 robot controllers, the IFI tech decided we should ship our 2006 RC back to Texas. We FedEx-ed it overnight.

An IFI tech called us the next morning to report faulty soldering connected to the programming port! He repaired the problem. We have it back, and things are working fine now… :slight_smile: