Phoenix can't see TalonFX

It can’t see it on phoenix tuner or phoenix tuner x however it can see it on rev hardware client but rev sees it as a talonSRX. It is blinking orange and the CAN bus looks fine. I’ve tried disconnecting all other falcons to see if it is a id conflict but it isnt and when I check on rev it shows it is 9. My code says it can’t find it aswell when I try and instantiate a TalonFX object which is weird. What should I do?

How are you connecting to the bot? (wifi/ethernet), Is it only one Falcon that wont show or all of them? Did you try running the temporary diagnostic server from Phoenix Tuner?

Just one, I am connecting via WiFi and I ran the temporary diagnostic server

For your CAN loop do your run a daisy chain or a central star/ring method? for context REV CAN systems starts viewing CAN from the PDH, whereas DS and CTRE start from Rio. This caused us some pain this year.

Daisy chain, when I plug the breakers back in they are all blinking orange

Do the LED’s blink the same as the rest or is it slightly different. The Falcon’s have multiple orange blinks codes as shown on page 39-42 (link)

All CAN devices are viewed from the perspective of the code trying to communicate over it (i.e. RoboRio). If you’re referring to what you see in the REV Hardware Client, that’s viewed from the perspective of the device you’re plugged into with USB-C (which could very easily be the PDH, but doesn’t have to be)

We had an intermittent connection on our wiring

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.