Phoenix Tuner keeps disconnecting from robot

I am trying to use the phoenix tuner to update the firmware on our Talon SRX motors. However, when I run the temporary diagnostic server, it says “Updating CTRE Devices” and displays the devices weirdly. I can sometimes see all devices, but other times it only displays some of the devices or displays some with corrupt names that appear to be a combination of two other device names. It then disconnects saying “Is Diagnostic Server installed and RIO boot complete? Connecting to”. When all of the devices appear they have different CAN IDs when I can see all of them, but when only some of them appear there is a device with a duplicate ID. We are using 5 Talon SRX, 1 Victor SPX, and 3 Spark MAX motors on our robot. Does anyone know how to fix this?

I’ll start by saying that Phoenix Tuner doesn’t connect to SparkMaxes, you’ll need the SparkMax Client to configure them. See REV’s website, it works differently than Phoenix.

How are you connected to the RIO? In my experience, connecting over USB-B gives the best and most stable connection.

Were you able to figure things out?

  • Make sure using latest Phoenix Tuner (Releases · CrossTheRoadElec/Phoenix-Releases · GitHub). Go to Help > About. At least Tuner 1.6 (latest is 1.6.5)

  • If connected by USB printer cable use the (default) or if connected via wifi to the radio use the 10.TE.AM.2 address. For 5968 that should be

  • With that you should then click Run Temporary Diagnostics Server. When you are finished you can run Restart for your robot code.

It should all be working then, but let us know what problems you might still have.

I have configured the Spark MAXs properly through the REV client, so I’m pretty sure the problem lies with the Talons. I’ve tried connecting to the RIO through USB but I get the same problem.

I haven’t updated the Phoenix Tuner yet so I’ll give that a shot. Our team doesn’t have access to the robot until after winter break, so I’ll update you then.

When you next have access to the robot, I highly recommend going through our CAN bus bring-up procedure:

Specifically, disconnecting all CAN devices and reintroducing them one at a time is the best way to isolate and fix wiring/CAN ID issues.
It’s also the best way to rule out if non-CTRE devices are causing any issues with the CAN bus. We’ve had customers previously report other devices introducing CAN errors onto the bus:

Thanks for Bring Up guide! It turns out the issue was with the CAN wiring.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.