Phoenix Tuner Not Connecting


#1

We started up an old robot to start testing new software for this year, but we have hit a roadblock. We used the Image Tool to update firmware to 6.0 and reimaged to the 2019 image. We then used Phoenix Tuner to install the files to the RIO. We changed the USB IP to our team number and it correctly found the mDNS address. Everything seemed to install successfully using the mDNS address, but now it says it cannot connect to the RIO at the bottom. When going to roborio-2010-frc.local:1250, we get the following:

{
    "GeneralReturn": {
        "Action": "",
        "Error": -120,
        "ErrorMessage": "CTRE_DI_NodeIsInvalid",
        "ID": 0,
        "Model": ""
    }
}

Any help would be greatly appreciated so our software team can get a head start!


#2

Use USB (172.22.11.2) or static IP.

We mention this in a couple places…
https://phoenix-documentation.readthedocs.io/en/latest/search.html?q=mdns&check_keywords=yes&area=default

I actually made some improvements to mDNS resolving, so roborio-2010-frc.locall will work better in future releases. But for now I recommend static or USB (172.22.11.2).

Makes sense?


#3

Will try this tomorrow.

Thank you!


#4

We are also having trouble getting phoenix tuner to connect.

We are connected to our roborio using USB.

We wired a single talonSRX through CAN and connected it to a motor. We are able to push code and drive said motor using the talonSRX.

We are able to see the talonSRX by using the getdevices command:

We are also able to Install Phoenix Library/Diagnostics:

Yet, the Lost Comm message persists at the bottom of the screen and we cannot see any CAN devices in the marked tab.

We have tried both 172.22.11.2 # RoboRIO Over USB and roboRio-TEAM NUMBER-FRC.local in the Diagnostic Server Address drop down.

We have also tried to force Start/Stop Server a few times.

I am at a bit of a loss as to where to go next in terms of troubleshooting. Any additional ideas would be greatly appreciated.


#5

Do this in order, so we have common setups.

  1. Enter 172.22.11.2 into the dropdown, plug USB into RIO.
  2. Then press install
  3. Then screenshot and confirm the success
  4. Wait 10 seconds
  5. report results.
  6. If bottom still reads “lost-com, trying to reconnect to 172.22.11.2:1250”,
    then turn off windows firewall
  7. close app
  8. reopen app and reproduce experiment.

#6

Thank you for the quick reply…I won’t be able to give your suggestion a try until Saturday morning. I will report back when I do.


#7

We found that other anti-virus software can also be blocking the application from using the required port to use the roboRIO (especially when using a school’s computer, in which there are third-party firewalls and blocking services that cannot be deactivated without the administrator password).

FRC CTRE Phoenix Tuner Loses Connection to the roboRIO


#8

Got a chance today to try the things suggested. We checked for firewall and anti virus software. We did have windows firewall enabled…so we disabled it and followed the steps suggested by ozrien and still was not able to connect.

One of the team members happened to have their MacBook…so we gave that machine a try. We WERE able to connect and see the CAN bus information, but strangely enough only over WiFi.

Still nothing with the windows machine.

Any other thoughts? I might mention that our windows laptop runs windows 7…not sure if that matters


#9

Responses

You didn’t provide the screenshot I asked for in step 3.

We want to see a screenshot indicating it can not connect to 172.22.11.2 despite the RIO deploy being successful, USB is connected, and the 172 address selected in the dropdown, and 172 displayed in the bottom status bar.

Tuner is a Windows .NET application. So I suspect the MacBook is boot-camp-ing into Windows. Otherwise your statement is confusing, or something is being missed.

When you usb-connect into the RIO, the NI driver creates a network LAN that can be confirmed in Windows Device Manager, or via “ipconfig” in Windows shell. A better test would be to confirm DS connection in all three use-cases (Eth, WiFi, USB).

That’s a good exercise for mentors/students since you need to prove out all connections strategies if you want to be robustly prepared for your competitions.

Next Steps

It does sound like your OS is not allowing Tuner to perform any web-requests for some reason. This really does sound like Anti-Virus software. Make sure Firewall is off for both public and private network connections.

  1. Retest after right-clicking on Tuner icon and selecting run-as-admin. I don’t expect this to resolve the issue, but this needs to be ruled out.
  2. Pull down a fresh copy of Tuner from https://github.com/CrossTheRoadElec/Phoenix-Releases/releases
  3. Uncompress to your Users/Documents or Desktop location
  4. Run Tuner (with admin if necessary)
  5. Rerun experiment.
  6. Post results here or support@ctr-electronics.com (email is faster than polling CD for new posts).
  7. In the menu-bar, Options => Advanced View => Enable
  8. In the menu-bar, Windows => Open Windows => Web Diagnostic Log
  9. Press “pause” button to toggle to the unpaused state. You will see transactions
  10. Clear a few times to ensure you are looking at fresh data
  11. Screenshot or use the tools=>capture-All menu option to capture the transactions.
  12. Post results here or support@ctr-electronics.com (email is faster than polling CD for new posts).

Side Note: Web Diagnostic Log is a great way to learn how the diagnostics works if you want to make your own front-end, or leverage the diagnostics as part of your robot application.

If you want a more expedient response then post-something-wait-a-day-get-response you should really just contact us at support@ctr-electronics.com. This is not a problem that should take days to resolve.


#10

We seem to be having an identical problem to the one described here, and I was wondering if you ever figured out the issue?


#11

We have not hit this problem as of yet, but a fix to the issue in case it shows up in the future would be nice.


#12

Fix is coming - (we’re in the testing phase). We have a total number of four confirmed cases of this, where the browser works, but Tuner doesn’t connect. Seems to be an obscure condition caused by Microsoft’s web-request stuff, and only occurs on a minority of PCs (none of ours of course).


#13

Finding the IP of the robot using the web dashboard and using that in the Tuner address worked for us. With the latest (5.12.1.0) version of the framework, it seems that mDNS is much more stable for using the team number. I’m not sure a fix was actually implemented in that version (we started on 5.12.0.1 at the beginning of the post) but it seems to be working now.

Remember that it will not say it is connected if you have not clicked the “Install Phoenix Library/Diagnostics” button. Even with the old version, if we clicked the Install button, it would connect using the mDNS address from having the team number in the box and install correctly. It would fail to connect after the successful installation to the RIO though. Perhaps it would be clearer if there was a message at the bottom saying something like “RoboRIO found - Phoenix Libraries not installed to RoboRIO”.


#14

Fix is out
https://phoenix-documentation.readthedocs.io/en/latest/blog/blog-week4.html#new-tuner-v1-2-with-diagnostic-server-v1-1