PhotonVision 2022 Official Release

Is there anyway to integrate this with LabView?

Everything is on NetworkTables so that won’t be a problem. It might not be as easy as using PhotonLib, but it should be fine, especially for basic things like just getting the yaw from a target.

4 Likes

Do you have an issue with PiCams? I have tried 2 different pi cams a 1 and a 2 with 2 different cables on 2 different pi’s and they see everything in a red hue. Anyone else having this issue

I was told to try the pi cam at a lower fps to help with exposure time. But I hadn’t tried that.

Hue is affected by white balance, which you can adjust by changing the “Gain” slider (yes, this name is confusing if you don’t hover over the slider and look at what the tooltip says—we will fix this in the future).

There is a thread here were they talk about this issue. I also am experiencing this issue. You can adjust the gain slider on the input tab to correct the color hue, however the image is still rather dark and colors are not super prominent. In the current version of photon you won’t be able to get the exposure much higher. The developers are aware of the the issue and I believe they will be making some changes in future releases.

I am getting an error when attempting to install photonlib to VS code. Has any one else encountered this lately? We had installed it on other laptops a few weeks ago.

Command ‘WPILib: Manage Vendor Libraries’ resulted in an error (network timeout at: …://maven.photonvision.org/repository/internal/org/photonvision/PhotonLib-json/1.0/PhotonLib-json-1.0.json

1 Like

Are you at a school or on a network that might be blocking that location?

It’s possible. I pulled the json file from another laptop and built the code. It seems to be ok now.

Hi,

We have been testing PhotonVision on our Limelight 2 with mostly nice results but have a couple questions:

  1. What is necessary to reliably save and retain pipeline settings in the Limelight? We’ve tried clicking the yellow Save button and also exporting and re-import but still the pipeline settings (we only have one pipeline defined) seem to frequently get lost for reasons that are unclear to us.

  2. is 1280x720 resolution supposed to be supported on Limelight 2? When we select it the target pitch and yaw angles output by PhotonVision are incorrect.

  3. Is there currently or planned any way to specify a cropped ROI within the image? This would seem valuable both to speed up processing and eliminate chance of false target detections in impossible areas (e.g. ceiling / floor).

Thanks!

These are both bugs. Pipeline settings should save automatically (not settings on the “Settings” page; with those you need to click the save button because you don’t want to autosave in the middle of changing your IP). The second one is possibly a result of an incorrect FOV adjustment on our end (that video mode has different binning that affects FOV, which we do adjust for, but it’s possible we got this wrong).

This is very doable and seems like it might be a good candidate for the next slate of features we implement.

1 Like

Thanks for the prompt reply! Is there any recommended workaround for the settings issue (e.g. SCP or REST call from roboRIO push the settings file automatically on every startup)?

You could certainly try to SCP from the roboRIO, but this isn’t an ideal solution.

Someone else just reported a data loss bug where one of their config files got corrupted when the battery voltage was very low—this can up in logs, so if you could click “Export Settings” on the “Settings” page and send the ZIP file here that would be super super helpful. We’ll also try to get someone to see if they can reproduce this.

Thanks. That certainly sounds like it could explain it as we seem to notice upon restarting the entire robot so maybe there is a brownout condition. We’ll export and send the logs next time we notice it.

If we were to SCP the settings, what is the target file / path that contains the settings?

we liked photon vision as well but due to randomly losing setting we went back to the limelight.

This is concerning, is there a tracking issue?

You can SCP from /opt/photonvision/photonvision_config. Your current logs might have valuable information (unless you’ve reimaged the device), so if you send them they may help.

Yes: https://github.com/PhotonVision/photonvision/issues/433

I have log export .zip but I get error new user cannot upload attachments

Could you maybe upload to Google Drive and send the link here? Alternatively, if you upload on our Discord server and @pietroglyph#9445 (my account) then I can take a look that way.