PhotonVision issue connecting to Cameras on Limelight 2 and Raspberry 4

I can run Photon vision on my laptop with a usb camera fine detecting
april tag numbers and 3d positioning. I connect to the wifi on my robot
and I cannot see the limelight usb camera. I loaded the image on the
limelight 2 from photon vision web site. The camera works fine and is tested. I do not
see it in photon vision as a drop down. I do see a camera listed in the default
driver station but no image and a address of 0.0.0.0 comes up.
I also tried a raspberry pi 4 ( brand new with a camera on board). I downloaded
the image from photon vision for it also. The strange thing is when it boots up
all I see is a cli ( command Line Interface). I was unable to run the window
interface to it. Is it native to the photon vision image? I can connect to the setup interface on the RPI and the limelight. I am using DHCP. Do I need a static IP and what should the settings be? Thanks for the help.

The resolution for this problem was a reload of the raspberry pi 4b with
the raspberrypi version from photovision.
https://github.com/PhotonVision/photonvision/releases/download/v2024.3.1/photonvision-v2024.3.1-linuxarm64_RaspberryPi.img.xz
To get the limelight and the raspberry pi to read the tags I had to be
as close to the camera as possible when doing the calibration and
set auto exposure off and manually adjust the image exposure and brightness before starting the calibration. Also the checkerboard has to have a white background and I used a white dry erase board to achieve this.
I will post later the limelight version that worked for my Limelight 2.

1 Like