Pingable LimeLight loses camera stream after network loss


#1

Hey all,
Coming from match day 1, I’m noticing an issue where in queuing we turn on our robots to do some last minute diagnostics. This happens to also turn on our limelights.

Our limelights are running DHCP, and are pingable in the commandline and the splash pages are accessible via the browser.

However, when we change over to connecting directly to the field (probably a network change is going on), the camera stream is frozen, but the cameras themselves are pingable and accessible bis commandline and browser respectively. The workaround for us is to powercycle the robot on the field.

This causes panic and frustration. Is there anyway to restart the stream via command to the limelight? Unfortnately we haven’t wired an on/off switch for our individual cameras.


#2

Have you tried setting your LimeLights to static IPs? Pick something in 10.TE.AM.10-20 range, netmask 255.0.0.0.

What dashboard are you using? The dashboard should automatically reconnect the camera stream.


#3

We were having this issue as well. We have static IP’s, but camera stream is frozen. We usually just do a check right before the match starts, but one time our robot lost comms during a match and restarted comms and our limelights weren’t streaming anymore. Weird issue, but we had no problems with our backup USB cams (MS lifecam 3000). We are using shuffleboard.


#4

we had camera issues on static ips during practice matches on shuffleboard. The CSAs recommended we go dhcp.

not entirely sure this is a network issue since cameras are pingable. although, networks are tricky anyway.


#5

Changing to dhcp wouldn’t effect the network tables stream of values, correct? (As long as we access it through the limelight.local:5801 address)


#6

Agreed, we had trouble accessing the mDNS address when we were static. We had instant success when switching to DHCP.

I wonder if the LL cant ping/reach the Network Tables Server, if it quits streaming after a while.


#7

I highly recommended using static IPs for everything. We recently posted some tips here. Moving to a static configuration has fixed a number of teams we’ve worked with.

http://docs.limelightvision.io/en/latest/best_practices.html


#8

Brandon,

We are having a slightly different issue. We have the Limelight2 firmware 2019.4 and it is losing its static IP address. Problem Description:
Set static IP according to provided LL documentation
Limelight reboots - static IP still good
Power cycle robot
Limelight IP address resets to dynamic and we no longer know LL IP to communicate with it

Solution we are trying to work this morning is to set radio and rio to static IPs to see if that solves the problem. Other than that any ideas?

Thanks in advance,
Robyn


#9

Robyn,

Can you manually type into all fields of the ip configuration page, then click the “change IP” button? Also, you should absolutely update to 2019.5.1 to help address this.

http://docs.limelightvision.io/en/latest/software_change_log.html#id1


#10

Brandon,

Yes, we manually change the LL IP according to your Best Practices post and LL documentation.
We will update to 19.5.1 here in a few minutes. We have set radio and rio to static IP as well but have not had a chance to test yet. Will update as soon as tests are run this afternoon.

Also, started a separate thread for this issue. Am going to paste your reply there for anyone else who might be seeing this.

Thanks again,
Robyn


#11

We think we got it figured out. Last night when they were trying to set the LL static IP they were working through the rio. Today they switched it to setting up through the laptop and it seems to be keeping configuration at this point.


#12

Team 987 helped us today at our regional and making everything static ip fixed our issue. Thank you again!


#13

Hey falcons, you were great partners at san Diego. I wish you luck for the rest of your comp season