Pneumatic compressor not starting

We need help programming the compressor to start in auto and teleop.

attached is a copy of the code.

Sorry, I can’t see your code attachment where I am.

The compressor only needs to be in, then it’s actually active in the background everywhere else.

Here’s the full set:

Move the so it follows the

That’s the only place you will need it for both Autonomous and Teleop.

The compressor part of looks fine. There’s no need for you to do anything special in Autonomous or Teleop; the compressor control is handled automatically by a separate task that the Compressor Start sets up for you. You can close the compressor in if you’re a stickler for making things “just so”, but it really won’t make a difference if you leave that step out.

did you check to see if you wired the correct paths for the specified components?

Also try a basic relay program to see if your relay is working (WARNING: be careful though, the comp will not off, so if it works, disable it right away). Then you know it’s the IO.

Have you electrical members check the wiring.