Pneumatic Control Hub compressor issues

Hello everyone. Our team normally doesn’t have any issues at all but are having major issues this year with the compressor. The compressor is brand new. It is not turning on when the robot is in teleop. I also tried holding the “mode” button for 7 seconds and it still doesn’t turn on. The LED on the hub for the compressor doesn’t light either. Sometimes when we access the hub and turn on a solonoid manually in the software sometimes it works.

It really sounds like your power is the problem. The fuse may be intermittent if that is what you are using. I highly suggest feeding the hub with a 20 circuit breaker.

What firmware version is loaded in the hub? What is the color of the status LED when enabled?

2 Likes

How would I go about this? can I plug it straight into the rev power hub slot with a 20amp breaker? Maybe i’m just confused from previous years where I thought it had to be powered via those little press buttons on the top of the hub

the newest version, 22.0.4 we just updated. The hub is green

No you use a 20 breaker in one of the PDH slots. See Table 9-3, you can power the PCM/PH from a circuit breaker. The compressor can have high start current sometimes that is sufficient to blow the fuse. The circuit breaker can handle the temporary overload without failing.
The terminals on the PDP/PDH are alternative terminals if you needed all of the available breaker positions.

1 Like

Will do thank you for this tip

I’m still getting these faults even after doing this step. The compressor also still doesnt turn on and the LED doesn’t light up

What is the difference between active fault status and sticky fault status of these errors?

Active means it’s happening now.
Sticky means it happened some time in the past.

Have you checked the wiring thoroughly. I mean going wire by wire, connector by connector, comparing with the wiring template drawing to verify that they are connected correctly and doing a pull test on each and every connection?

Do you have an old compressor you can connect into your system using some temporary wiring to verify that everything controlling the compressor is working. You do not need to install the second compressor in your robot. You can even leave it in your practice bot or some old chassis. If the second compressor works, it may mean your new compressor is bad (DOA).

Try plugging into the USB on the PH and taking a look with the REV Hardware Client. While there, double check the firmware and see if you can run the compressor or at least get the LED to light from there. What type of pressure sensor are you using, and how is it connected?

Thank you everyone! It was a combination of issues I’ll explain below incase it helps anyone. The compressor issue was due to our pressure switch power pole being unplugged (face palm)

The other issue I will be contacting REV about is our hub was faulty. It is brand new and whenever we move the switch to 24v it displays 0v on the Rev software and doesn’t work. We touch the switch lightly and it goes to 24 then 0 then 24 etc… the switch was super buggy.