Pneumatic Hub and Pneumatic Control Module problems

Hello!!

My team and I are having problems with pneumatics. We first used the new pneumatic hub which we bought two of. Our first one gave us hardware errors and second keeps flashing different errors. We switched it out for our second PH. At some points it says the wires are communicating while it says there’s power but no communication. When we power cycled it was green but then a minute later it turned purple. We’re using REV hardware client but the PH gives no indication that anything is happening.
We have switched out wires, checked for any exposed wire, and were out of ideas.

Close up photos of your wiring might help us help you.
Shots of the PH, shots of the CAN connections, shots of the pressure sensor and compressor connections, shots of the power connections back at the Power Distribution, etc.
Poor connections at the Power Distribution or PH can cause intermittent errors.

Is the firmware (22.0.4) updated on the PH?

What size fuse/breaker do you have the PH circuit using?

Does the compressor activate if you hold the mode button down continuously for more than 7 seconds.

Can you USB into the Power Distribution Hub and see/access the Pneumatics Hub with the Rev Hardware Client?

Purple status probably means a communication error with the roboRIO.

I’d recommend reading through the wiring specs on REV’s site: https://docs.revrobotics.com/rev-11-1852/pneumatic-hub-specifications

The two things that I could see tripping people up are not using the correct wire gauge or the correct stripped length of the wire. For us, it took putting a ruler next to our wire to realize that we didn’t have enough of the wire stripped.

I would also recommend reaching out to REV’s support at [email protected] with a description of your problem.

Thank you for your responses! We will share pictures this afternoon when we have access to the robot.

The PH is connected to the PDH with a 15a breaker into port 20 (the top small one) and has power because the status led lights up.

The firmware has also been updated to the latest version.

We have not tried running the Compressor with the mode button as we have been trying to just get the Solenoids to fire.

We are able to access the Hub with the Rev client through USB into the PDH or PH, although even when directly plugged in using the client with the robot on, the Solenoids still do not fire and their leds do not light up to show that they are firing.

We do not remember the specific errors, but we will share along with images of the wiring. We have not been getting any can errors though so i am not sure if that can still be the problem.

We are also not sure if the wiring is the issue as even when trying to run it with the Rev client with USB, it still does not even light up the solenoid leds to show it should be firing.

You have to be careful in how you try to use the Rev Hardware Client to test the PH.
We can’t just plug in to an active robot and use the Client.
The PH won’t respond if it is currently or has ever been connected via CAN to the roboRIO during the current power cycle. This lockout is a safety feature. The Rev Spark Max’s behave the same way.

To use the Rev Hardware Client to control/test the solenoids:

  • Turn off all robot power (so the PH isn’t powered through that)
  • Disconnect the USB A -C cable from the PH (so it isn’t powered that way)
  • Disconnect one of the CAN wires from the roboRIO (so the RIO can’t talk to the PH)
  • Reconnect the USB A-C cable from the PC to the PH (now it’s powered and hasn’t talked to the RIO)
  • Repower the robot (the PH needs full power to operate the solenoids)
  • Use REV Hardware Client-choose the PH and try turning one of the solenoids

Thank you for your help! After looking at other threads we have now got the Rev Pneumatics Hub to both connect without any errors (by setting it to can id 1) and fire Solenoids (by using your advice running through the client without can connected).

However, we are now still having issues with getting our Compressor to run. We used the mode button and it works, but we are not sure how to turn it in the code. We are currently trying to use the Rev analog pressure sensors, but we also have the Nason digital sensor if it is easier to get functioning.

The compressor operates automatically if you have at least one solenoid declared.

The analog pressure sensor must be in the analog port 0.

If you still have difficulty, the digital sensor is usually easy because there is only one place to plug it in.

Do you know a reason why it wouldn’t happen? The 2 solenoids are declared and they work, but the Compressor light doesn’t even turn on. The analog sensor is also in port 0 and shows data in the Rev client.

I assume the Driver Station is Enabled?

Since the mode switch worked to run the compressor, and the mode switch is only bypassing the pressure sensor, it would seem to be a problem with the sensor or it’s connection.

The easiest test is to try the Digital sensor in place of the analog switch.

1 Like

Are you using java? to use the analog sensor you have to tell the PH to use the analog sensor by calling enableAnalog.

https://first.wpi.edu/wpilib/allwpilib/docs/release/java/edu/wpi/first/wpilibj/Compressor.html#enableAnalog(double,double)

1 Like

Yes, we had Driver Station enabled. We wired a digital sensor last night and will test it this afternoon.

We are using Java, and tried enableAnalog with values at 100 and 120 and still nothing happened.

I have been using the Digital pressure sensor with the hub and connecting the Analog pressure sensor into a RIO Analog port so I can use the pressure reading directly.

I haven’t actually tried to run the hub with just the Analog sensor, since I want to use the pressure reading directly in my RIO code. I’ll see if I can hook up a test myself.

Ok, thank you! We will try that this afternoon.

Btw, you can get the pressure (and raw voltage) that the sensor is reporting from the PH.

1 Like

Where is that in LabVIEW?

That’s a good question, and I don’t have an answer for you. I haven’t installed labview this year, but i would expect it to be with the compressor functions. Perhaps I’ve made the naive assumption that feature parity would be maintained for labview teams.

Nope

I take it back, I can get the pressure reading from the Compressor Get Enabled state.

Thanks for making me look!

1 Like

Okay, after firecrafty made me go look, I was able to test running the PH on the analog pressure sensor.

I explicitly set the Feedback to “Analog” and the Max/Min psi
However, it only ran on startup when it charged the system

It worked once to charge up the system, but didn’t kick back in when the pressure dropped below the minimum.
I fiddled with the minimum

  • 95 no
  • 105 once then not again

I’ll keep playing…

1 Like

Having problems with my PH on either sensor.
This is what I’m seeing.

It runs twice after being Enabled:

  1. first chargeup of the system
  2. again when I release pressure the first time

Then never again.

I transferred to a PCM and it works as expected.

I’m still experimenting.

Was it working before with the digital?