Pneumatic System Help


#21

Going to Ramp Riot. Would prefer to fix it before it though.


#22

Try uninstalling and reinstalling the Pheonix Lifeboat config on the roboRIO


#23

A couple of years ago, CRTE gave me a price of around $20 for replacing the Weidmuller connectors on a VRM. If you have a dead CAN chip, I would expect a similar price. I did not end up sending it in so I don’t know how long it would take them to turn around a repair.

It would be best if YOU PHONE CTRE to find out how much the will charge for the particular repair you need and how long it will take them. They are pretty easy to talk to and very helpful.

Have you tried swapping in a new RoboRio? If it turns out your RoboRio has a bad CAN chip, you should phone National Instruments to find out how much they would charge and how long it would take them to fix it for your.


#24

Don’t currently have any spare electronics to swap in or out. How can we tell if it is the roborio thats the issue without having to swap it out?


#25

Can you get in touch with a team near you and borrow one? Swapping in a know working RoboRio is the simplest and fastest way of determining if it is the CAN transciever chips in your RoboRio that are the problem. That would be the first step I take with the boards I design at work.

If forced to troubleshoot a situation like this where I have only one sample of the board available, I would be using an oscilloscope to monitor the CAN lines to make sure the output waveforms went to the appropriate voltages at the appropriate times.

Has your team ever had the PCM working?


#26

No we have never had a PCM working and I might be able to get a RoboRio from another team.


#27

This might be a good time to find a team near you that is successfully using the CAN bus and meet with them. Preferably, find one using the same programming language that you are using. Bring your robot and programming laptops when you visit them. If you have never been able to get a PCM to work, you may have some sort of software issue. They may see something that you don’t know is wrong.


#28

After looking through the thread, this thought jumps to mind. Please check that all the CAN bus wiring has been stripped. I have a number of teams each year that have the CAN wires installed but they were never stripped or at least not stripped to the correct length. Try a pair of wires between the PDP and the RoboRio only and see if you can address the PDP as suggested above.


#29

Yes! The Users Manual for the PDP and PCM gives the strip length needed to make a proper connection. These manuals can be found on the CTRE web page for each of these products.


#30

I tried all these suggestions and nothing worked. Roborio power light is still red and when I connected Roborio to PDP with CAN, the CAN lights on PDP were still blinking orange. Nothing appeared on roborio web dashboard either.


#31

The PDP blinking orange is actually a good thing.
It means the PDP does detect the roboRIO via CAN, and vice versa.

The orange just means the PDP has detected low battery sometime in the past. It will stay that way until cleared by the user through code or through the webdash.

Now the webdash just might be due to not having updated the roboRIO with the current webdash update from CTRE.
After the roboRIO has been flashed, it needs additional CTRE installation of the CAN webdash software.

The first step is to install the CTTRE Phoenix onto your PC: CTRE Phoenix Framework Installer 5.8.1.0 (.zip)
So, CTRE has a guide here: https://github.com/CrossTheRoadElec/Phoenix-Documentation#installing-phoenix-framework-onto-your-frc-robot


#32

Ohhh I see. Any idea what to do about the red light on roborio though?


#33

A red power light on the roboRIO is a different issue.
It’s unrelated to your CAN or PCM issues.
What it means is that no power is being supplied through one or more of the sets of power pins (the center ones) of the roboRIO 3-pin ports.

The Red power light means there is a short on at least one of those roboRIO output pins. The PWM, DIOs, MXP pins around the edge of the board.

First, look at the Driver Station Power tab. That will tell you which power output(s) have the short (3.3v, 5v, 6v).
Then have someone with good eyes inspect the corresponding power pins on the roboRIO for junk, typically a tiny sliver of wire whisker fallen into the pins.
The other potential cause is a short on one of the things plugged into one of those roboRIO ports.



#34

Ahh I see. Thanks a lot.


#35

Shine a bright flashlight into these areas. It makes any extra metal bits that shouldn’t be in there show up much better. Also, look (and shine the flashlight) at different angles.


#36

Also, just to ensure the code is correct, would one of you guys mind looking at it if I post it?


#37

Ok I fixed the Roborio red light and the PCM is showing up in CAN network (the Phoenix Framework wasn’t installed thanks for that tidbit). When I self-test PCM it says the compressor current is too low. Does this mean a bad compressor or does could it be that the wires are connected weakly?

EDIT: It also says the PCM is not enabled which I suspect is a code issue?


#38

PCM not Enabled just means you don’t have the robot Enabled from the Driver Station.
It will also occur if your user code hasn’t referenced any solenoids. In that case the code isn’t trying to talk the the PCM at all.

Compressor Curr too Low sounds like a wiring issue.
You can test with a multi-meter.


#39

what should the current be?


#40

Current draw will depend on the compressor.
P.S. I think that error means the PCM does detect some current draw, so it’s not totally missing or disconnected. A typical compressor draws maybe between 9 and 16amps steady state with a momentary peak above 20amps when it starts up.

Test first that you have 12v available at the PCM’s compressor output pins.

If you have a splice further along the wires you can test there as well (or temporarily add a set of wires between the PCM outputs and the compressor leads just to give you a spot to check away from the direct PCM contacts.