Pneumatics problems

We have an issue where the pneumatic solenoid valve won’t move when we press the button on the controller, the respective side of the solenoid lights up a solid orange but the valve does not move and send air to the opposite tube. We are using a double solenoid in which the intake is in port one and the exhaust is on ports 4 and 2. The program is the same as on the wpilib website.

Is it by chance a 24 volt solenoid being powered at 12 volts?

Please post what model solenoid you are using. The part number is normally printed on the side and usually have the voltage needed as part of that number…

Also how much pressure are you using? Solenoids require a minimal amount of pressure for them to actuate. Many of the Festo used in FRC need 30psi present to actually shift.

Good luck this year.


We had this or a similar issue a few days ago.
Most of the solenoids used in FRC are air-piloted. This means that without air pressure, the valve does not move. We are using the Vex manifold-based solenoids for the first time, and one of our cylinders is single-acting. The port intended for the return stroke was “creatively plugged” in such a fashion that the supply air was vented directly to the atmosphere, apparently dropping the supply pressure at the manifold below the pilot threshold. When they switched to separate solenoids, things worked fine. We are again working with the manifold-mounted solenoids.

Alright, thanks for replying but, I guess one of our guys changed the voltage maybe and that got it. So, it works now but thanks for the input