POE Injector Only Carries Data If Barrel Connector Plugged In

We have run into an issue that has stumped our programming and electrical teams:

When we power our radio with the REV POE Injector plugged into the 18-24v POE port, the radio powers on and we can connect to its wireless network and our Tegra TX1 coprocessor on the attached network switch. However, we have no connection to the roboRIO and the light for that port remains off.

If we plug the barrel connector from the other 12V/2A output of the VRM into the radio, the port’s light comes on and we have communication with the roboRIO. Any ideas?


Have any video of it?

First I’ve heard of this issue.

I don’t have a video of it. We can probably take one tonight, but it’s really not that exciting to watch.

No but it might provide some additional clues to help diagnose the issue.

I would check the connectivity, cross-connectivity, and resistance of each conductor of your injector, beginning with the POE lines. Each line should have only a few milliohms of resistance, and there should be no cross connectivity.

Also check the output of the VRM from the port you’re using.

I wonder if the RIO’s providing voltage at too low a level to complete the connection? I don’t have any way to check right now.

The crimp connections on the orange POE cables are a little marginal. (We recrimped our’s and had not had a problem.) Maybe too much voltage drop in the cable. Enough to power up the radio, but not enough to power the wired Ethernet? Just a WAG on my part.

I have heard of some issues with the orange POE cables. Not enough to cause a riot, but if it’s causing you problems, it’s better to swap it out than keep struggling with it. Amazon has some for fairly cheap - I know both of these have been used on robots without issue:

A POE splitter is identical to a POE injector, except for the barrel jack, which you’ll cut off anyways. So each of these gives you 4 that you can use for only $8, 2 day shipping free with Amazon Prime. Plus, they wire up opposite the orange one - they plug directly into the RoboRio, and let you put the long ethernet between them and the radio. Really handy, since the power is usually near the RoboRio anyways - this way you don’t have to run a long power cord as well.

I find it to be all around better than REV’s - easier wiring, vastly cheaper, and faster shipping. For the $10 Rev wants, along with another $6 for shipping to get it by the end of next week, I can get 8 of these.

The POE splitter from Amazon (at least the ones I have) are backwards from the REV ones. Power is injected into the female plug, not the male plug. So you have to power the injector plugged into the RIO.

If you are having issues with our POE cable please send us an email to [email protected] and we will get it sorted out.

The ones you linked to will work if you know what you are doing. The reason that ours is a bit more expensive is due to the way it is made and the relatively small qty produced. Making the power connections in the female side of the cable is much easier since there is a PCB inside there (thats how our first samples we gave to FIRST were). After discussions it was decided that it is much safer for teams to put the power in the male connector. If you connect the POE cable incorrectly and send 12v into the roborio you can and will likely kill it. The other issue with the off the shelf ones is that some of them that we found had power connected through both ends, so the roboRIO would be getting part of that 12v power regardless.

I have seen the REV cable installed backwards (male end into the roboRio) and the roboRio was not killed. I also remember hearing from NI (I think through some data sheet, but I cannot find it now) that the Rio can survive pretty much any miss-wiring if it does not exceed 12 volts.

From our knowledge the RoboRIO is not explicitly protected from this, but there are alot of protection inside the RIO, so it is possible it survives. All we can say is that we recommend that teams use caution.

The power is on the “spare” pairs of the Ethernet cable. I would be a little surprised if they are actually connected to anything in the RIO.

I have seen POE equipment damaged from 48 V POE being plugged into a device expected 24V POE

As an FiM Southfield CSA, a rookie team showed up with their POE cable installed backwards at their first event, and unfortunately it did take out their RoboRio Ethernet port.

Both LED’s on the RoboRio ethernet port were solid on, even without any cable connected. The RoboRio would tether and function fine over USB in this condition, but would not communicate over Ethernet.

Tried obvious things like reloading firmware and swapping radios, but eventually swapped out the RoboRio advised that they contact NI for a replacement / repair.

We have spare POE Injectors, and will swap it out, but we were interested in understanding how it was even possible for the ethernet cable to only carry data when the barrel connector was used. Everything else appears to function normally, but there might as well not even be an ethernet cable between the radio and roboRIO unless the barrel connector is plugged in.

The issue you are reporting is a really strange one. My guess is that if your POE cable is bad and you are not getting enough power to the radio that it isn’t actually on and looking at packets. If the Barrel jack is providing the right amount of power to power the radio than things would work as expected. I would try swapping your POE and see if the same situation exists. If so send us an email and we will replace the defective cable.

The radio powers on without the barrel connector. We can connect to its wireless network and SSH to our coprocessor or view the camera feed. Without the barrel connector, however, the light for the POE’s port doesn’t turn on and we cannot SSH to the roboRIO or connect to it with the driver station.

Please try a new cable and report back.

Could conductors in the cable be severed?
When barrel plug is in place it may be bending the cable in a way that damaged pairs make contact with one another.

When everything is plugged in, can you bend the cable and get it to lose comms over Ethernet?

We replaced the POE Injector, but the issue still occurs. We are planning to leave both plugged in, and hope for the best.

Here is a link to a video of the behavior, as requested by marshall.

Man that’s weird…

Any chance you’re willing to open the radio up? Kinda curious if there is something happening inside that might be obvious.

Have you tried re-flashing the latest firmware onto it?