Portable VSCode Install

Is it possible to install VSCode (And WPILib) to something like a USB? Or if not, is it possible to just copy the installed files onto a USB, if so, which ones and where are they?

I ask because I have a bunch of university computers available to use for software training, however I cannot install anything to them (volatile storage) so the program will need to be run from a network drive. Is there a better solution?

A quick google search yielded this: https://code.visualstudio.com/docs/editor/portable. AFAIK, that will also keep any extension data WPILib.

I’m not quite so sure how a portable WPILib install would work, given I don’t know how the VSCode extensions search for compilers / etc. @Thad_House / @Jaci would probably know that one.

WPILib’s Visual Studio Code install is itself in portable mode, actually. (Everything is self-contained within %PUBLIC%\frc2019 or ~/frc2019.)

You will probably have problems if multiple computers try to use the same portable VSCode installation concurrently, I suspect.


The concurrency shouldn’t be an issue if I have multiple copies of it.
However when I try to either deploy or simulate, I get an error saying Can't execute a shell command on an UNC drive using cmd.exe. I assume this is because it’s on the network drive and its trying to access it via its network path (\\host\path…), however the folder is mapped as a drive (U:\path), so is there a way to tell it to use that mapping instead?

Try creating a new project, and then add a folder to the project from your root directory. Then, open a new command shell using the menu, shortcut keys or (I think) WPILIB button. It should let you choose the root.

This is especially true if you have multiple folders added to your project.

I know it works for us with Python anyway.

~Mr. R^2

1 Like

If you open vscode from the mapped drive rather then opening it from the UNC path it works.

This is actually a Gradle restriction, along with a windows restriction. Command prompt doesn’t work with UNC, and even if you work around that issue Gradle still crashes.

1 Like

So that seems to have worked, seems the problem was also that I’d opened the project with the UNC path also. There was also an issue with the JAVA_HOME variable being set incorrectly but that was easy enough to fix.

I now have a problem where upon trying to simulate the code, I get a Cannot create debug adapter (no executable specified in package.json). error. Any idea?

What did you do to get the JAVA_HOME to work?

I don’t remember entirely, but I believe it was one of the following:

  • Rebooting
  • Using a fresh install
  • Setting the Windows environment variable
  • Messing with vscode variables
  • Messing with project variables

I remember doing all that, but don’t remember what actually made a difference, if any.

I’ve since abandoned using this solution for my use case as the computers would take about 2 hours to compile the project. Just unzipping the program took long enough.

I know you can install on a USB drive because that is what we did to our driver station laptop. I believe I reset a variable in the pre kickoff release, but I can’t remember how well it worked. FIRST released a fix to this problem in the post kickoff release of the environment. WPIlib also has the following command
WPILib: Set VS Code Java Home to FRC Home - Set the VS Code Java Home variable to point to the Java Home discovered by the FRC extension. This is needed if not using the offline installer to make sure the intellisense settings are in sync with the WPILib build settings.”
here is a link for installing advice
here is all of the WPILib commands.
Good Luck!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.