Post-Competition Wireless

we were trying to get our robot to run wirelessly with the router that had been given to us in the kit of parts for a demonstration, however we were only able to get the robot to run while tethered

can you please provide more information? have you checked to see that none of the settings have been changed. Are you able to ping the ip address? Was it working fine before the matches?

I’m not sure if this will help, but try doing a hard reset on your gaming bridge (the black one on your robot) and reconfiguring it. Maybe the WPA code was still set from your last regional.

Did you reset the WPA?

i know that at our regional, some teams actually did get the wrong WPA key, just try reconfiguring the wrt610 also.

I had the same problem after returning from Atlanta. Even after resetting the bridge, I was still unable to even sign on to it (wired or wireless). Finally I took the device home and plugged it into a wired only router and suddenly had no problems at all.

I guess the inability for the wireless to connect somehow stopped the wired connection from working as well.

Hope this helps,
Darrell

Unplug the lan cord that runs to your crio from the gaming adapter (unplug it at the gaming adapter)

  1. Reset the gaming adapter to factory. (There is a small button that can be depressed with a paperclip to reset it. You may need to hold this button down.)
  2. Run a wire directly TO the gaming adapter from your computer port.
  3. Go into your computer’s network properties, go the network adapter you are using, then highlight the TCP/IP settings and click properties again. Set the settings to
    IP address: 192.168.1.(anything except 250)
    Subnet Mask: 255.255.255.0
  4. Log in to the gaming adapter and follow the instructions found on the first website under control systems, chapter 5, Section 5.6.1. You want look at the gaming adapter configuration specifically - start at step #5.

Link to control system manual:
http://www.usfirst.org/uploadedFiles/5-FRC_Control_System-Configuration-0-5c.pdf

This should enable your gaming adapter to work again with system. This is assuming your Router setup is STOCK, without any WPA added. After you’ve finished with the directions in the manual (starting from step 5), unplug you network cord from the gaming adapter and plug your gaming adapter back into your CRIO. Reboot everything.

Please note, after the step where you reset the gaming adapter’s IP and subnet, you will NOT be able to connect to it from the IP address and subnet I listed above - so when you save it in the gaming adapter and it reboots, your web browser will no longer be able to pull up the page (unless you change your subnet and IP back to the programming settings of 10.team.number.6 and 255.0.0.0).

Don’t forget to set your programming computer back to the correct IP address to program.

Actually what likely happened is that by performing a hard reset of your Wireless Game Adapter you restored it to the default address which is in the 192.168.1.xxx range. Your team’s Wireless Router was still set up for the 10.xx.xx.xx range and would give your computer an address in this range as well. This would prevent you from accessing the Wireless Game Adapter.

It did reset and I was trying to use the 192.168.1.250 default address. I just couldn’t get it to talk to me till the wireless router was out of the picture.

Right, your wireless router was setup using the 10.xx.yy.zz range where xx and yy are your team number. When you took the device home and connected it to your router it worked because most people leave their home networks setup with the default 192.168.1.xx addressing scheme.

Connecting it directly to your computer would have worked just fine as well, as listed in the procedure posted above by Tom Line.

We had a similar issue…

It could be one of any number of things:
*At the competition they install a wep key on your bridge(on robot)
– I would reset all of your devices, (hold reset button and restart)
– you may have issues with ip addresses, (set computers to auto config)
– then reconfigure according to 5.6.1 Configuration of Wireless Bridge for Robot (WGA600N)

*During a demonstration while our robot was tethered, it stopped working
– bad Ethernet port on drivers station

contact me if you need more help
blake (at) team2648.com

That PDF would have been really useful to have downloaded before yesterday. We had a demo in the basement of the TX capitol, so there was little wireless reception, and all of the capitol wireless networks were hidden and encrypted, so no internet. But I managed to get both of our 2009 robots working again after about an hour and a half of hacking.

I used the “Wi-Fi Protected Setup” tool on the router. Basically, I setup all the correct settings on the router that I could remember (all encryption disabled, team number SSID’s, IP pool range) and then followed the instructions for the Wi-Fi Protected Setup. I couldn’t get anything to work until I had all the right things configured in the right way at the right time, which was as follows:

  1. IP address on the computer set to 10.team.num.6
  2. ALL encryption disabled on the router.
  3. Computer connected to router via ethernet hard line.
  4. Bridge connected to router via ethernet hard line.
  5. Press the Wi-Fi Protected Setup button on the bridge (on the front, picture of a lock).
  6. Click the Wi-Fi Protected Setup button on the router (through your web browser, logged into 10.team.num.4, on Wireless>Basic Setup).
  7. Wait for the operation to complete.
  8. Repeat if it doesn’t work.
  9. Drive robot in front of baffled congressmen.

Having done very little networking before, that was fun to do from scratch. Thank goodness they got roaming wireless mode to work on Ubuntu 9.04.

Three choices:

Connect router to PC with ethernet cable and access web page of router (http://10.xx.yy.5) to enter the encryption key into the router (We were given a printout at our regional with the key).

or

Connect router to bridge and router to PC with ethernet cables and access web page of the bridge (http://10.xx.yy.1) and turn off encryption.

or

Reset router and bridge to factory defaults using the reset buttons and follow directions in chapter 5 to reconfigure them

http://www.usfirst.org/uploadedFiles/5-FRC_Control_System-Configuration-0-5c.pdf

What will turning the encryption off do?

We are having the same problem. Our robot works tethered but not wirelessly.
Our problem is that the person who normally helps with the router issues is not able to help us today before the board meeting at 3 pm EST.

If it will take a while to do, we will just go with tether and try to redo it tomorrow, when we are not in such a rush.

Can anyone walk me through it?

Thanks…

Encryption either needs to be on at both ends (with the same encryption key) or off for there to be communications.

Everything is still set the way it was at the Michigan State Competition.
We have not changed anything. If that helps.

I don’t have a bridge around to check this with but I believe this is the procedure to disable the WPA encryption.

  1. Plug a computer into one of the 4 ethernet ports on the Router and the Wireless Gaming Adapter into one of the other ports.
  2. Open a browser on the computer and go to 10.12.54.1
  3. You should be prompted to login
    Username: admin
    Password: admin
  4. Click Basic from the top set of tabs then select Wireless from the tabs below.
  5. At the bottom of the page next to “Security Mode” change the box to “None”
  6. Click “Save Settings”
  7. If prompted to reboot, click “Reboot Now”.

Your Gaming Adapter should now be able to connect to your router wirelessly again.

As soon as everybody is done posting either A the same thing or B whatever they did, can we get a single stickyed post or link that has what we should do to fix this for future reference? =)

Just a quick note to say thank you for all of the help. We got it up and running. After reading all of the suggestions we decided to go with the reset everything option. After resting the router and the gaming bridge and then reconfiguring the IP address to both of them to match the original protocol we are up and running.

Thanks again - you are all a wonderful resource.