power distribution board red light stays on

We’re getting a red light on one of the 30 amp outputs of the PDB when there’s nothing connected to it. We believe it is the cause of an issue we’re seeing when we increase the speed of our shooter wheel. Whether this is the cause or not, at higher speeds, everything cuts off and the driver station indicates a communication loss but it’s very brief and then we’re able to start back up. Several watchdog errors pop up, system and user.

We tried to add a breaker to that port even though it’s not being used and noticed that while pushing down on the board itself, the red light for that port goes off. However, it is difficult to tell whether anything improved b/c it’s difficult to keep pressing down on the sweet spot that keeps the light off thus causing the same problem of everything cutting out and then back on.

If anyone can shed some light on what we might be experiencing, it’d be greatly appreciated. Thanks.

The red light is supposed to indicate that there is an electrical load connected to the PDB output and the circuit breaker for that output is open (or missing).

If there is nothing connected to that position’s red Wago connector but its red light is on, there is something wrong with your Power Distribution Board.

A brief loss of communication is very suspicious. How brief is it? Less than a second, a second or two, fifteen seconds, or what?

Furthermore, if a breaker is only solving it when you press down on it, your power distribution board is likely broken (broken trace? bad solder joint?). The connection between the PDB and the breaker is very tight.

Before I answer the question, I suggest contacting EricVanWyk, who helped design the PDB and is far more knowledgeable about troubleshooting it than anyone else here on CD. That being said:

Just to make sure there’s no confusion at all, this means the light turns on when there is no fuse present and there are no wires connected, correct?

This sounds like a power issue with the DLink; have you made sure that the barrel provides a secure connection and that the converter is hooked up to the dedicated output?

To reiterate Alan’s question, how long does it take to reestablish communications? You may also want to observe the DLink lights when you ramp up shooter speed and see if they turn off; if they do, then you know you’re having issues somewhere in the power connection.

The new DS allows you to graph the voltage over time; have you tried identifying a voltage threshold at which your communications cut out? Seeing as how the dedicated input is designed to function down to a 4.5V battery, I doubt the PDB itself is your issue, because it takes a massive load to cause a voltage drop that big.

Could you clarify what happens when you do what? i.e.

  • Does adding a fuse, 20A or 30A, rectify the problem?
  • Do you push down onto the fuse itself, or somewhere else near the suspect slot?
    IMO, there are metal shavings and/or a bad connection in your PDB, which would explain the errant light and intermittent connection.

The PD board is a little confusing the first time you look at it. :slight_smile: The little lighting arrow points to the circuit the CB is protecting putting the CB on the opposite side. So make sure you really have a CB in the correct slot.

[edit]Read you post a little closer. Sounds more like a bad trace on the board.[/edit]

Thanks for the responses. Let me answer some of the questions asked…

How long does the power cut out? The power will completely cut out and the driver station will disable itself requiring us to re-enable to continue.

SLIJN, yes, this is all occurring while there are no wires connected to the output and while there is no cb connected on that particular port. We’re not using the DLINK…we’re connecting directly from the laptop to the cRIO with an Ethernet cable. I will check the voltage logs.

Does adding a fuse, 20A or 30A, rectify the problem? Do you push down onto the fuse itself, or somewhere else near the suspect slot? We started by trying to push the fuse all the way down and noticed that the light would flicker on and off. We then try to seat it just right so that the light would go off but it would only ever go off temporarily (no more than 20 seconds or so). Pressing on the PDB near where the fuse is also causes the light to go out but it’s so touchy that it comes back on if you’re not pressing in the “sweet spot”.

The brief loss of communication was seen when we pressed down on the board, trying to keep the light off, and we witnessed what appeared to be a breaker tripping (the power cutting out). But, instead of the driver station disabling completely, the power would cut out but then come back on immediately (within a second or two). Again, this scenario only happened while we were actively trying to keep the light off by pressing on the board. Otherwise, the driver station would completely disable itself. So when I say it lost communication, what I’m really trying to convey is the fact that the driver station indicators all go to red, the robot communication indicator included.

sounds to me like you have a short in your PD board(metal shaving, wire strand, etc. got in there) and it’s causing brownouts… how long do the lights on your driver station go out for? 2 seconds? 10? 30? more?

Slijin - I appreciate the props, but it is always better to post to the board than to PM one specific person. I may have designed the hardware, but I’d argue that e.g. Alan is more experienced with the system than I am.

The blown breaker detection circuits are very small, simple and isolated from the rest of the circuitry. They don’t share any circuitry with the radio power supply. I am leaning towards physical damage to your PD. Did you drop or bend it? I saw one team using it as a springy back stop to catch their arm as it dropped last year.

Here’s the PDB schematic, so you can see how the circuit works. http://www.usfirst.org/uploadedFiles/PD%20Schematic%20v4.pdf

I am going to agree with Erik here. The LED comes on to indicate that a current path exists but that the breaker is open. Inserting a breaker and pushing it down to extinguish the LED sounds like you are forcing the board below the case or you are pushing down the board until the circuit path opens. I am betting you will find metal shavings on the board or underneath. Using a bright light, look into the WAGO connector and see if you see any crud in either of the ports before opening the PD.

Again, there are two ways…First, if we’re actively trying to keep the red light off on that port by pressing down on the pdb or by inserting a breaker, the driver station will disable itself and come back on within a second or two. If we’re not touching the board and there’s no breaker present, then the driver station will disable itself and stay off until we re-enable.

It sounds like we should also check for metal shavings or other debris in the pdb. Thanks for the comments. I’m hoping that’s what was causing the driver station to cut out and not something else. Thanks again!

Ryan,
Since the power supplies are at the opposite end of the PD from the power input, it is possible that conductive material is shorting out the board but I would expect to see some smoke with that kind of current. It really sounds like you have a broken (cracked) circuit board. It is pretty easy to open the case and check inside for foreign debris. Is this a brand new 2012 PD? If it is you may not want to open it without checking on warranty repair or replacement.

We can run the shooter wheel fine until we get up to about 5000 rpm. That’s when we notice it starting to give out; we can hear the motor whirring up and down a bit and then it cuts out. I’m not sure if it is a new pdb or old but we’re going see if there’s debris in the port at all. I’m not sure how long this has been going on with this pdb and no one seems to know what might have happened to it.

I pulled our board apart and this is what I found. On CB1 the trace that goes from Q5 to R9 was broken away from the board and folded over. I do not know how this could have happened unless it happened as a factory defect. This board was purchased fall of 2010 and installed as a retrofit to our 2007 machine as a fall training project. This board has never seen competition play and has been sitting dormant since Fall of 2010. I’m thinking this trace was already broken and since it was part of a retrofit of a machine that never really saw much action once the retrofit was complete, we never saw this problem.

My confusion lies in that if this circuit is isolated why would it affect the rest of board when we saw high current draw on another breaker.





Jimmy,
That is not merely folded over. The transistor (or what remains) of Q5 blew away from the board taking the stripe with it. What is more interesting is that none of the other transistors are in place. During the initial rollout, there was some reason that the ‘breaker open’ tally circuitry wasn’t included. Erik Van Wyk likely remembers why but I don’t. There is a lot of debris on the board that may have led to this failure. Please note the solder splash on the lower right of the transistor pad. I am going to bet this is also a contributing factor to the original problem.

Al, that is what it looked like to me. But what is strange is if you look at the CB next to it and at its transistor, Q6, the same black pastic housing is not there. So did they install a different transistor in that postition than in any of the other positions. Also, the trace was completed folded over the plastic piece was next to the wago terminal. I folded it back to try read the markings on the plastic.

This is the 2009 revision of the PD. There was an error in the design of that circuit that required the rework of several thousand boards. It looks like you somehow got one that didn’t go through QA correctly. This is the first time I’ve heard of this error “in the wild”. The issue was permanently solved for the 2010 season.

Snip the trace that has been pulled up and make sure it isn’t shorting to anything, then put some kapton or electrical tape over it. I’m really sorry that you had to deal with this.

That explains the LED being ON all the time except when you pushed on the board. I would follow Erik’s suggestion, a sharp blade across the trace will make life easier. Double check the solder though, a simple hot iron should reflow the solder so it isn’t a problem.

Great Thanks! We will try this tonight and see if we can replicate the issue.