Pressure switch not activating

Hello everyone. It seems every year I run into this issue in some sort and it’s just naturally been going away. Basically for some reason our pressure switch is wired up the the rev pneumatic hub (if it wasn’t wired it the compressor wouldn’t turn on right)? anyway it will not trigger and the compressor just runs until it shoots out the relief valve. This was not an issue last week. I verified the switch is connected properly. We use the relief valves preset from andymark.

I have no clue what is causing this especially when the only thing that changed was we swapped out our hub and also swapped the reliefe valve out.

Any advice would be welcomed

1 Like

We had a similar issue; updating the firmware on the hub solved it for us. We had to try it twice.

1 Like

I would also check the wires to the switch. If the two wires are shorted to each other (e.g. a loose strand at the PH end), the switch is read as closed.

We currently have this where we think the wire isn’t seated all the way into the REV Pneumatic Hub (it’s unfortunately in hard to access location) and we can get the compressor to turn off and on by moving the wire around.

One of my teams tested three pressure switches before finding a working one.
They were all older switches that had been kicking around for a few years.

We figured it out. The new relief valve we were using which was brand new was letting air out around 110psi and so the switch never activated