Printer cable stuck in Rio

The printer cable is stuck in its port on our Rio. it has no clip and we have never had this happen before, however we are pulling it with more force than we feel comfortable and it is not budging. Has anyone ever seen this or have a suggestion?

Well, I’ve never heard of that happening before since “Printer Cables” (AKA: USB Type B) don’t have clips like Ethernet cables.

I would try these things if I were in this situation.

  1. Try pulling from different angles, one of them is bound to release the connection.

  2. Try squishing the connector from the outside and pulling to get it unstuck. Its unlikely this’ll be effective but it might help.

  3. If none of those work and there is almost no way to get it out, try to find a way to securely leave the entire cable on your robot without breaking any rules.

Not sure how much this helped but let me know if you find out how to get it unstuck.

1 Like

Unfortunately we have had this happen to us before.
Over time, it finally broke the socket, rendering it useless.

So, since it was broken, we decided to repair it. We ordered a couple of extra sockets.
We removed the board from the case and proceeded to remove the conformal coating. That was an exercise in frustration! Finally we desoldered the socket and soldered in the replacement.

That Rio now lives on our prototype board and works like a champ.

2 Likes

This has happened to our team before. We found out that one of the connector plates had bent. We used a flat blade screw driver to bend the plate down again. Once it came out we bent the plate back so that it wouldn’t happen again. It probably wasn’t the best way to fix it but it worked so…

I read printer cable and thought something completely different. I feel old. Anyhow, I have heard of this happening. I never recommend repair yourself. Call NI.

1 Like

We have had this happen twice, I found that electrical contact cleaner sprayed into the sides of the connector while it was stuck was able to loosen it up and allow me to pull the cable out. I honestly didn’t expect it to work at all but it just came cleanly out right after I sprayed it.

This is the stuff we used I think - https://smile.amazon.com/CRC-Plastic-Contact-Cleaner-Aerosol/dp/B000BXKZVA/ref=sr_1_4 , you can buy this or similar at most auto parts stores.

For somewhat mysterious reasons, the USB port on the Rio includes claws to hold onto inserted cables. They really aren’t designed to ever let go, unfortunately. Imagine a lobster trap.

It is possible to slip a shim, a thin piece of metal, between the USB port and cable to depress those features and withdraw the cable, but it’s tricky and usually requires a little back and forth before you get all the way out.

The ‘correct’ way to use the USB port is with a short USB B male to USB B female bulkhead connector. That cable is inserted and stays in place, while the bulkhead port is mounted somewhere easily accessible.

1 Like

this happened to the Bisbee team recently with the new Rio they got. Tech support (from AM and then NI) ended up suggesting they leave the cable in place, then get the Rio repaired/replaced by NI when NI has some replacements in stock again.

I don’t think it’s mysterious. TBH, this is a really great addition for something that moves around and vibrates like a robot. Imagine how much better life before POE would have been if the barrel port of the radio had one of these. Until it won’t let go when you need it to, of course.

that’s the problem, the connector is REALLY stuck in there.

This is your key to getting the cable out. I found that a really thin piece of plastic worked a little better though. I needed to use 2 narrow pieces, opposite from each other on the two long sides of the square (the angle notched “top” of the port not being one of the sides you insert in). When both pieces are inserted all the way into the socket, the cable should release. I found that the socket outdents were a little too aggressive and the particular cable I was using allowed them to extend a little too far into the connector. A little judicious use of a jewelers screwdriver “formed” both parts to prevent it from happening again. I happen to really like that particular 15 foot cable for use around the field if I need to get a team’s roboRIO working.

Isn’t that the same technique used to free the alliance wall from the carpet during field breakdown? Amazing how widely solutions scale.

Maybe there are uses of the USB port Im not aware of, but is it ever really used when the robot is really in motion? I thought it was just a means to connect to the Rio in the absence of a working tcp/ip connection, or for updating the image and such. In that case, I think Id rather the cable pull out of the jack, then the jack out of the PCB .

I dunno, the fact that this is a recurring issue for a lot of teams suggests it’s more annoyance then help. NI ought to at least do a better job of making the behavior of that port better known.

3 Likes

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.