Problem Connecting with OM5P-AC Radio

After imaging the roboRIO and updating the firmware on the radio, we tried to upload code through labVIEW. However, we weren’t able to connect to the robot to upload code.
The laptop we are using connects to the robot, as we can connect to the network. When connecting through the dashboard, the communications indicator on the dashboard is green, but code is red.
The wifi light on the radio is solid yellow, the comm indicator on the roboRIO is solid red.
We configured the radio using the newest configuration tool, we tried methods suggested in other threads such as putting a name in the optional robot name section of the tool and turning off IPv6 connectivity. Pinging the RIO doesn’t give us any results either.
If anyone has any suggestions, please let us know.

Have you followed R63?

From your description it sounds like your radio is fine and the roboRIO is fine.

Check your LabVIEW project explorer window to insure that your team number is entered correctly (see attached example).

You can test by connecting your PC directly to the roboRIO via a USB cable, however you must change the project Target from “roboRIO-####-FRC.local” to “172.22.11.2” in order to Run as startup over the USB connection.

LV-TeamNumber.jpg


LV-TeamNumber.jpg

This was likely the problem, as we were able to upload code when we switched laptops. Thanks!