Problem downloading to CRio

Using WindRiver under 2012 spec, we were able to compile and download repeatedly with the new compile replacing the old in the cRio and executing as expected. Now, after updating all components to 2013 spec, we see the following problem:

After reboot of cRio, we are able to download c++ code and it runs as expected. There are some errors that I don’t understand, but the code does run and does what we expect. If we then recompile and download without reboot of cRio, the download appears to work and our code starts (we can see console trace of class constructor being called) but then our program fails with a c++ exception. We never reach the point of enabling auto or teleop mode. We have to reboot cRio to be able to download and run successfully.

I will have attached the console output from a successful download followed by one that fails.

Robot_Console_Trace.txt (6.05 KB)

Robot_Console_Trace.txt (6.05 KB)

Are you undeploying? I’ve had problems with that in the past. I haven’t used C++ in FRC in around 2 years.

In order to run code that you just downloaded, you have to reboot the CRIO. If you do not, you will be running the same code that you had before you downloaded. The new code needs to be loaded, and the only way to do that is to reboot the CRIO.

Are you sure about that? Under 2012 spec, we downloaded repeatedly without reboot of cRio and it worked fine…

First of all, if it comforts you, we’re having the same problem just like you.
We think that the problem is in deleting memory in the cRio. We tried another cRio and it also didn’t work, so we think now the problem is with Windriver 2013. We try now working with LabView and as for now the problem doesn’t exist…
We also posted a thread here here’s the link:

In other teams the 2013 Windriver did work, so there must be some problem we didn’t encounter yet.
Is your problem is similiar to what I describe?
Do you have some clues what to do???

GreenBlitz 4590

Undeploy isn’t needed to my knowledge, seems more like a supersticious focus (or possibly a vestigial operation from before my time). In reality the deploy operation FTP’s the compiled .out to the robot, overwriting the existing file, I assume undeploy removes the file, but you can redeploy over the file just as easily.

Have you reimaged your cRio with the new imaging tool for 2013? The updated image would be required for working with the updated WPIlib.

Yes, all software is 2013 spec. Note we are not yet using deploy/undeploy. We are just using the WindRiver Run function to download the code into non-permanent storage.

Hello, we are from GreenBlitz 4590 and we have the same problem like you. We use 2013 windriver and updates, as well as the 2013 DS and cRio verion 2.
We also posted a thread in this forum:

We also can run the robot for the first time, and after that the debugger can’t run the code or when we enable it in the DS it shows us errors in the diagnostics window.
We thought maybe the problem is in the cRio, so we tried to change cRio (version 1) but it didn’t work. We thought it might be because of the Windriver Workbench - when we tried a sample labview code it worked good.

We can run the code pretty good but we need to reboot the cRio each time. It’s not so bad but maybe it’s because of a deeper problem. We know that there are teams which don’t reboot the robot between runs.

As for now we don’t know what caused the problem. We are now exploring deeper the problem. If you have new information write to us in one of the thread, and we will write when we will come to new ideas

Greenblitz 4590