Problem Getting Victors to run with the new control system

My team’s programmers are having a problem getting victors to respond to any commands from labview
as of this afternoon they got a single signal to victors but they were not able to get them to run just sputter

we have all updated software and reimaged the cRio with the most current version today rebooted and still couldnt get the victors to respond to any programms on a regular basis

i do not think it is a wiring issue in that i have cross checked all wires and PWMs with jaguars and the jaguars run with no problems but when the wires are put into the victors and programmed using the victor sub command they do nothing

has any other teams had this situation and if so how did you solve this problem

TEAM 932 appreciates any input that could help in this situation

Ignoring the minor neutral point difference, Jaguars and Victors should be essentially interchangeable. If you move a PWM cable from a working Jaguar to a Victor, it should act nearly the same, as long as the Victor is receiving power correctly.

Do your Victors’ status LEDs flash yellow under the same conditions where the Jaguars are working properly? The PWM input to a Victor is notoriously difficult to plug into without a lot of practice. You might just need to get the connector to go in right.

I thought I was having a problem with programming victors in labview. I tried changing my code a good number of times. I finally found out that pwm5 did not work for some reason. I even tried to change out the digital sidecar and still just pwm5 didn’t work. Anyways, I haven’t seen another team post the same problem, but you might want to try using a different port than you are using now.

i can see having having only one port not work correctly like chmp09 is saying but we have three victors on ports 5,6,7 and none of the three work properly

we have had an extension of the same problem arise since we have replaced the victors with jarguars in that we cannot get any motors to run outside of the drive system when we combine the mechanism program and our drive program

Last night we noticed that when we had three Victors on one Sidecar we had problems, but when we moved one to the second sidecar all three worked fine. We also had four Jaguars on the first Sidecar. There might be some impedance/current issues with too many speed controllers on one Sidecar. This is just a guess at this point.

For clarification, we changed out the problematic Victors with Jaguars, and are still having the same problem.

We can run the four drive jaguars using the start 4 motor command, or we can run our other three jaguars using the start motor command. However, if we try to do both, nothing works.

we also are only using a single digital sidecar with 7 jaguars plugged in to it (75.3 KB) (75.3 KB)

Do the lights on the jags blink like they are disabled or are they solid?

Also, connect your computer to the cRIO when you run the cod. Does the open motor vi or the set motor give you an error? If so, try to trace it to the source.

What is happening is that you are sending the signal to the robot as a jaguar.
Under the open motor, you see a drop down menu, select Victor instead of Jaguar.

I don’t think that this will cause a problem because we have switched out victors for jags. Also, they said that they had replaced the jags with victors.

My team is having to switch to victors because the jaguars we have failed. and our victors aren’t doing anything but flashing. the code has been adjusted to run victors instead of jags and when it’s enabled they flash as though there is no wire plugged in, the pwm cables are plugged in correctly, I’ve tried using several different slots on the DSC and get nothing… any help would be greatly appreaciated

Make sure you’re paying attention to the dates, this topic was made last year. We had a similar problem with v20.