Problem onnecting our DS to the 2017 update.

So, basically i cannot get the driver station to connect to our robot, We started having problems after updating our roborio and our radio to the 2017 software, We originally started having mDNS errors, which were resolved by installing Apple Bonjour, Then we got to uploading code after updating our eclipse plugin.
Allthough we are still having problems with the DS, Under the driver station the only green light on the connection status page is the “Robot Radio” label. Reinstalling the suite did not fix issues and we have been halted at the programming part of this.

In short term to what we know, We think that the driver station does not like the new mDNS address and won’t connect, I also want to mention that the radio light on our RIO does not light up.

-MrARM, Programmer for Team 1737

If you have a green light to the radio, you are certainly connected to that, so I wouldn’t be looking into problems with networking on the computer anymore. That’s solved.

What happens when you tether directly to the roboRIO and then try to load code to it? Does your code compile successfully? Is your RIO up to date?

That doesn’t absolve the PC network yet, so I have some questions about that, too.

From a command prompt do an ipconfig /all and see what the

  • DNS suffix is (near the top)
  • WiFi IP assignment is

I think this is a different question. But we can no longer get the Dashboard to display after updating the Driver Station this evening.

A little more detail?
Is this the default Dashboard or Smart Dashboard?

For instance, my default Dashboard and the new Driver Station I get feedback on the Dashboard about the joystick position.
Do you, or are you talking about something else?

The Default Dashboard that shows autonomous selections and shows the camera view. It usually loads above the driver station

It looks like the update deleted the default dashboard. We have copied from an not updated machine, but are having some difficulties seeing camera.

Just to chime in - we had a baffling problem with the update, and ended up reverting, with the hope that it would get sorted out before competition.

For us, it was that the driver station would not see the rio. We could ping, and deploy code, and tcp seemed to be working. But the driver station would not see the rio.

We’re time crunched for bag day, so we reverted. We did see this problem with two different radios, and two different laptops, both of which worked fine before the update, and after reverting the update.



I just found a PC where the Dashboard exe gets removed, and not replaced, but the original ones didn’t encounter that.

It seems to be because the folder was restricted to Administrative access.
I dragged a new Dashboard in there and had to give permission to move it there.

So, right-click and Run as Administrator on the setup.exe might avoid the missing Dashboard issue.

That sounds like the Dashboard<->roboRIO user code didn’t complete their connection.

After you have your Dashboard set to view the camera, reboot just the roboRIO (from the Driver Station Diagnostics tab) to see if the camera view appears.

Or close and restart the Dashboard to see if that picks it up.

We have resolved our issue, Apparently the mDNS service was not running, Which was set to manual start. From the start menu to typed “services.msc” and started the NI Discovery service. Then set it to automatically start.

The DS immediately recognized it and started working. :smiley:

Thanks for letting us know what the answer was.:slight_smile:

Back again

I tried the administrator mode but it makes no difference. I have tried this on 4 PCs and not one loaded the default dashboard that displays camera and Labview NT information. We are using older version of the dash board and most NT info is displayed, but carmera will not display even after roborio reboot

Here’s a just built Dashboard if you want to try it.
It probably isn’t much different than the older one you are using.

What programming language are you using?

When you’re connected with the DS, would you look at the Diagnostics tab and see if the robot ping indicator on the left is green?
I found a radio that allows the DS to connect with green Communications & Robot code indicators, but does not show the roboRIO ping as green and does not display the camera feeds (because of the disconnect). (1.88 MB) (1.88 MB)

Dashboard works. We added “.local” to the camera address to get the picture to show.