Problem with 2004 Robot

Our team has been storing our robot from last year in a closet, and until about three weeks ago it had not been run since the end of May. When we got it out the other day we started it up, and began working the controls. It seemed to be working fine, but then it suddenly just died. The electrical systems would start up, and the controller lights would turn on, but nothing would happen. We didnt think too much about it until this week when we decided it would be good to get it running. All we could think was that something had happened to the program in it. As we could not find our old program, I wrote a simple drive program for it and we loaded it and it still didnt work. Over the course of today we loaded every single program on every single computer we have, and none of them will work on it. After we load a program the program state light will go on solid green, then if we press reset it changes to orange. The OI flashes no data/radio and the OI radio shows transmit but not receive. The robot radio goes to standby. :confused: Has anyone else had this problem, or know a way to correct it? We tried the new radio modems, we tried the tether, and nothing seems to work.

stupid question…have you put a freshly charged battery in?

Yes, we have put in a freshly charged main battery, but our backup battery has to have run down by now (we plugged it in anyway just in case it needs to detect its presence) , and we have another one charging tonight.

Having a very dead backup battery can cause the robot controller to act very erratically. Charge it up and try again.

Really? How about running without any backup battery?

Russel, same thing happened to our 2004 robot, it turned out to be an electrical problem for us. I traced it down to the victors, apparently if the motors reach a higher than normal amp-rating, the victors just die, but then just completely removing the brake/coast jumper fixed it all.

Ok thanks, I will try both at lunch tomorrow.

If it was working with tether and now it is not, remove the backup battery and try again. If the backup has not been charged in a while, it might be shorted. If the robot functions with the battery removed, suspect a bad battery. NiCads sometimes go reverse voltage when left for some time uncharged/unused. Try a charge cycle and see if it takes a charge before recycling.

If the OI shows transmit but not receive, wouldn’t that imply a problem with the actual RC (since you’ve already eliminated the possibility of the modems causing the problem)? Did the RC get roughed up in storage at all (because that would probably be permanent damage) and/or are there any loose wires?

237 has also had problems with the AC adapter for the operator interface going. It worked one second and then it died or both the robot controller and the operator interface would keep reseting and the robot would jump. Replacing the AC fixed this issue.

Our AC adapter burned out yesterday anyway, so we are using the new one from this year. It didnt work with the old one or with the new one so I dont think that is the problem. I am going to go try the other suggestions as soon as a “responsible adult” arrives.

Ok, I tried all your advice, and beleive it or not none of it worked. I was at that point convinced that the RC was fried, but then I thought back and remembered something about the controller getting into a funny mode. I couldnt remember how to fix it but I remembered that it had to do with pressing the buttons in a certain order. I played around for a while and finally I got it figured out.

For any teams that may encounter this problem:

  1. Press down and hold both the program and reset buttons. Only the top battery light should be on and it should be red.
  2. Release the program button and continue to hold down the reset button for several seconds
  3. Release the reset button
  4. Go run the bot into a locker and smash door in (actually your school might no apppreciate this and its bad to ■■■■ off your school)

so it works now??? :confused:

Even though it seems to work now what you may have done when playing with the buttons on the RC you could have hit a cable or moved a cable to get in there. The serial cables for the radios get damaged very easily and when you get any small damage to those wires, or just letting them sit for some time can cause them to not work. I would recommend to get a new set of serial cables and replace the cables between both the oi and oi radio and RC and RC radio. This is something i recommend not only your team to do but everyone to do, especially in between any 2 events you go to.
Good Luck and hopefully you got it to work before.