Problem with Default Program/Deploy

This was posted over in electrical, but I am having the same problem and hoping anyone in here might have some insight

“I have been trying for two days to get the default program to work on our test bot. I have been able to update the classmate both driverstation and labview. I have been able to format the crio both wirelessly and through crossover cable connection. Labview acts as if the program is deploying yet nothing happend on the bot all lights 2 jaguars and green on sidecar, remain flashing. The drivers tation program says no code in the status screen. I have tried running the program in labview instead of deploy both with the run on right click and the arrow. Nothing seems to be effective. Any suggestions would be very welcome.”

I’m wondering if you might have to remove all the old data from the C-RIO. I’m not really sure if that helps or not. I want to say that the build specifications have something to do with it. Make sure that you can deploy your old code too. You might have a bigger problem.

we’re having the same exact problem. We imaged the cRIO and things seemed to be going well. The only things that seems to be wonky is that we can’t deploy the camera VI’s because we don’t have a valid activation code and are running on the 30 day evaluation. Would that cause the problems we are experiencing?

What happens when the run arrow is pressed? Without that info, it is hard to diagnose what may be wrong?

Greg McKaskle

The program starts and the strip charts on the main.vi form start scrolling. The only thing I have hooked up are the two joysticks. The joystick stripchart does not respond. I know the joysticks are active because I see their status in the dashboard app. As stated above though, dashboard also shows no program is present.

It sounds like your program is running, just not as desired.

My recommendation would be to open up an example program and run it. If it runs, there is no problem with the cRIO, image, or network. Some of the examples use joysticks, and they can also be used to test those connections and configurations.

As a bonus, if they work and your program doesn’t, it gives you something to experiment with to discover the cause.

If you want to post code or a picture of your diagram, we may be able to spot the issue as well.

Greg McKaskle

If the Driver Station saya “No Code” this means several things:

  1. You have good communications with the robot (otherwise it would say no-comms)

  2. You aren’t running a robot program.

I haven’t tried the release code yet, but It was my understanding that the cRIO image would NOT have a default program in it this year… that you’d need to “deploy” your own program…

So, if this was the case, doing a reset on the robot would cause it to behave as you have indicated. (no code)

Easy to test. First try running the program using the run arrow. This will deploy and run a “temporary” program.

If this works, then you need to do a “Build” and set it as the “run on startup” program. Then you should be able to do a reset and still have a running program.

Note: the flashing light status has changed this year. Blink off is good in teleop.

Greg,

We have both ‘ran’ and ‘deployed’ code, with similar results. The results are:

cRio is running the code. The camera works, along with the default ‘find the circle’ code. Gyro output is displayed. PWM values change on the dashboard when the joystick is used. However, there is no output to the Jags. Jags flash like they are disabled. EStop was used and all diagnostic lights were in the green.

To test this further, we used the Arcade example and ran it without changes. Same result, except of course, you can’t see anything on the dashboard. DBO is attached to slot 4.

We’re also having problems with deployment here. When we deploy the code (java) it looks like the cRio receives the program and is ready to run. When we reboot it, however, the dashboard says No Code. Comms are fine. Do we need to select an option somewhere to run the code as startup? I can’t find an option for that anywhere in Netbeans.

From those symptoms, the things I’d check are to see if the cRIO version is v19. Using 2010 WPILib with a 2009 cRIO image will look sorta like this.

Second thing to check is if the watchdog has triggered. The diagnostics page has a place for errors to display, and when a watchdog triggers, it will printout and display the number of triggers that have taken place. I honestly don’t think it is the watchdog because the example does the same thing, but if the first test doesn’t explain it, I’d double check the watchdog anyway.

Another test I just thought of is to add a relay test. The relay module has LEDs which indicate whether they are working or not, and they are guarded by the same watchdog as the PWM. If the relay in slot 8 doesn’t light up, I’d investigate the watchdog more fully. If the LED and therefore the relay I/O works, I’d actually look at the power and wiring to the Jaguar.

Greg McKaskle

On the cRio imaging tool the only image option is for 2010 v5. The driver station says that the cRio image is ‘LabVIEW - 2010_v5’ also, though we selected Java in the imaging tool. I’ll try looking at the watchdog now.

If the cRIO image is not v19, then that is definitely a part of the problem. The v19 definitely gets installed with the LabVIEW update. I’m not sure if it gets installed with Java or C++ updates. No need to spend time on watchdog or anything else SW related until you get v19 on the cRIO.

Greg McKaskle

For reference the Labview updates can be found here:

http://joule.ni.com/nidu/cds/view/p/lang/en/id/1534

Since the cRio imaging tool is part of the Labview suite you’ll have to install the update for several reasons including getting the v19 image.

Don’t forget to update your driver station while you’re at it:

http://joule.ni.com/nidu/cds/view/p/lang/en/id/1535

I know there has been some difficulty with the driver station update installer not correctly updating all it’s components.

http://www.chiefdelphi.com/forums/showthread.php?t=79935&page=3

The solution presented on the thread above and the solution that worked for us was to run the update installer and ask it to remove all the components and then run it again to reinstall them. (One of the big symptoms of this problem is the camera module on the dashboard not functioning even when the camera has been initialized and is communicating with the cRio fine)

Similar problems here.

We have downloaded the patches for the cRio and the Driver station.

Joystick program can be downloaded, and run. However, the joystick does not respond on the Labview screen.

However, when we switch user to the Driver, the joystick responds when you move it/press a button.

Any thoughts?

We had a similar problem and it ended up that our module to the digital sidecar was in the wrong slot. It was in slot 6, when it should have been in slot 4. Hope that helps…