Problem with our Victor?


we’re a new team, and our speed controller seems to be acting up and not working right. We’re wondering if anybody might know why, take a look at the picture.

Thank you,
your help is much appreciated.

The Ned Pirates



I circled all the problems I could find in red…
First, check your wiring (make sure there are wires connected)
Second, your PWM cable is not fully inserted (it actually appears that it is missing)
Third, you may have burned all the FETs because your fan is missing.

That’s about all I could find.
Except the fact that it is cut in half…



Dead battery idiot.


we forgot to mention this, but we took a look inside the capacitor, and there appears to be misshapen, twisted, and melted metal. Also, it wiggles around on the circuit board quite a bit.

We tried hooking up a PWM cable and the battery, but no go. It’s still dead.

We’re still investigating the issue about the fan.

Thanks for the help so far!

This has to be one of the strangest threads I have ever read :confused:

I suspect a bandsaw was the culprit…

And on a somewhat related note, I have seen dog training clickers from petco that sound EXACTLY like a breaker tripping… May have used it last year…

I cannot be absolutely certain, but I think the Victor may be leaking. With it powered up, check for escaping electrons. If you find any, locate the leak and plug it, then top up the magic smoke if necessary.

I am not positive, but I believe that may be an illegal modification of an electrical component. You may want to Q & A the GDC before you use a Victor with the modifications you have made. (NO DON’T REALLY CONTACT THE GDC)

Looks like you got a defective victor … as long as the warranty stickers aren’t broken … IFI should replace it :rolleyes:

I believe this part of the Victor is missing

Contact IFI for replacement magic smoke

You could contact IFI now, or you could simply go up to spare parts when you get to your first regional.

You know, I have seen thousands of Victors over the years and hundreds of damaged ones. I have seen every conceivable defect, power hooked up backwards, power to the output, metal shavings, contact with a wayward robot arm, even a broken battery cable contacting the FETs, but I have never, ever, seen this before.

I think the problem exists between the electronics board and the chair/stool. But who knows, maybe even then it doesn’t exist.

Thank you all for your gracious help! We really do appreciate it.

We’ve been investigating the issues you’ve mentioned, and we came to the conclusion that there wasn’t in fact a fan on top, so we mounted one on it. (See pic 1.) We also thought that it wasn’t getting enough energy, and since gold fish give us energy, we put some on there as well. There also is a battery.

However, it still didn’t work. We thought it might be dehydrated, so we added some water. (Pic 2.)

It STILL doesn’t work. We suddenly realized that the electrons must be leaking out, so we got some masking tape and masked it all up. Since the fan wasn’t working on top, we did a counter-top configuration, hoping that would work. (pic 3.)

We realized that the fan was pointed in the wrong direction, so we rewired our configuration so that the fan pointed towards the electronics. We also forgot water in picture 3, so we poured some on the counter so that we would get good conductivity.

Unfortunately, we still have 0 workage (at least in joules). We are wondering if anybody has any ideas, because we’re up to here in it, you believe me.

Thank you,
The Ned Pirates

P.S., does anybody know where we can get any magic smoke? IFI is on backorder right now, and so is Papa John’s. Thanks!

Picture 004.jpg
Picture 001.jpg
Picture 002.jpg
Picture 003.jpg

Picture 004.jpg
Picture 001.jpg
Picture 002.jpg
Picture 003.jpg

You may want to get the trunk monkeys working on this issue. Every car has a trunk monkey, and they can usually fix anything. I still believe the issue resides in a bad connection… Did you try to solder the fan to the victor? It’s hard to solder plastic to plastic, but it can be done! Doing this will also make some magic smoke, so gather it in a jar!

You know, I think Don Rotolo is right, I can see some electrons leaking out in one of the pictures. What you need to do is go find all the electrons that dripped out and return them to the module. You might have to go to a local electron supply depot to get enough to completely fill the device. Then you will need some Acme Electronik Leak Sealer with testing dye. Use according to the labeled directions and certainly wait the required length of time for it to cure. I believe it may need a vacuum of at least 40 inches of mercury for the curing process. Then you will need a variable voltage source, and starting at a very low voltage (1x10^-10 volts) and slowly advance the power supply while watching for the tell tale electron leak to occur. Most repair stations will perform this in a photographic room with the lights off. If all the electrons leave at once then I am afraid this device may be impossible to repair. Give it a good funeral and bury in the back yard along side Fluffy, the faithful goldfish from your youth.

Your Victors came with the wrong topology… They are supposed to work in an H-bridge, yours had a short "I-"bridge. Call IFI and claim DOA! :stuck_out_tongue:

You have too much whitespace between the sections of the victor. Remove it and apply duct tape (not masking tape) to seal it.

Also, the Coriolis effect may be causing the electrons to orbit the central capacitor in the wrong direction. Did you obtain this particular speed controller from the southern hemisphere?

There is no problem at all with this Victor. It is simply undergoing mitosis. Wait a few days and you should have two nice new Victors ready to go. Isn’t that how IFI does it?

If you simply can’t wait that long, I suggest you use the bandsaw to induce mitosis in your RC, so that it is at a similar state of division and better able to communicate with the speed controller.


Would zipties help?