Problem With Talon SRX Enabling

Hello, I am Lord Supreme Programmer at Team 1410, and I need some help with a rather large problem. We are currently testing out our electronics board and we have found that if we connect through USB and enable our robot everything works fine and all of the 14 Talon SRXs change from flashing orange to solid, but when we connect over Wi-Fi and enable the robot only 8 random Talon SRXs will change from flashing to solid, the rest will stay flashing, which is a huge problem. Does anyone else have this problem/does anyone have a way to fix this?

Sounds like a cabling issue that has revealed itself after you started driving it around (on WiFi).

Or the robot is genuinally disabling due to network packet loss. Check the driverstation for packet loss.

Did you update the talons to 1.1 or greater?

I don’t think it’s cabling as we weren’t driving around and the wires are soldered to each other. I checked and turns out over WiFi we get 50 to 60% packet loss, which seems abnormally large. Tomorrow we will try switching out Ethernet, router, computer, and a combination of the two. That is a huge amount of loss!

Can you post a picture of where you have the D-Link mounted? It’s a radio and is susceptible to interference from nearby motors, wires, speed controllers, and switching voltage regulators, as well as simple metal structures.

Don’t have a picture, but here is diagram. Board is made of aluminum, but I don’t think the placement has anything to do with it. We took the router off the board and moved maybe 10 feet to plug into through Ethernet to re-set it and it still had problems.





Don’t you think that maybe putting a radio’s antennas up against a large piece of metal would have a negative effect on the radio’s operation? :ahh:

We took the router off the board and moved maybe 10 feet to plug into through Ethernet to re-set it and it still had problems.

Do you mean you are still seeing high packet loss when you are using a physical Ethernet connection instead of Wi-Fi?

Well like I said, we removed it from the board and it still had the problem. We only plugged in through Ethernet to go through set up again, we still tried through WiFi. Also, the router does not directly touch the metal, it has two layers of Velcro and some gaffers tape between the two, even if it did, since when were the antennas exposed on the outside?

What program language are you using?
What happens if you start with 7 talons enabled and then add one at time and verify that they work?
I didn’t see or understand, does using an ethernet cable behave the same as using the usb cable ?

Also, when you switch to wi-fi, make sure you have all the other network inter-faces disabled.
Also, do you have an another wi-fi network interfering with your wireless? You can use a network display tool to see how many wi-fi signals are around you.

Alright I’m going to answer all the questions you asked so bear with me:

  • We are using C++
  • We have not tried the 7 Talons at a time, but will today (my electrical engineer will hate me for that as they’re already soldered)
  • We have not used ethernet as when we first got the roboRIO the electrical team insisted on deploying code and imaging the roboRIO through ethernet, even though we were told not to, so iI have banned connecting directly through ethernet, but we will try
  • We have other network interfaces disabled, but we do have other WiFi networks in the school, but I do not believe that would be the problem as we have never had the problem before.

When I said disabling the Talons, I meant within the software – just define a limited set to initialize and use. I did not mean removing them from the electrical connections.

When you send a picture, please make sure there is a good view of the power wiring between the radio and the VRM.

Please also send a screen shot of the driver station log viewer, showing a run of the robot where you’re experiencing the problem.

There’s nothing wrong with using Ethernet to program the roboRIO. I do recommend connecting the tether to the radio, rather than directly to the roboRIO, so that when someone trips over the tether it wrecks the cheaper device.

Have you gone on the webpage for the roboRIO and ID’ed the Talons properly? If you go there and you have less than 14 Talons on your left sidebar, they aren’t ID’ed properly. Also try opening the error log while testing.

To the last three posters:
I will do that instead of removing them physically. Pretty sure I just heard my electrical engineer sigh with relief.
Also the problem with using an Ethernet to connect to the roboRIO to deploy code is that if it’s the first time connecting drivers will not be automatically installed. I have had this happen multiple times. And, just to be fair, 80% of our deploy problems went away when we switched to USB, so I think it’s safe to say USB is the better option.
The picture I sent was a hand drawn screenshot at 2AM, and I am also not an electronics guy, so sorry there is no wiring. I know it is a standard router is plugged into the VRM, I think that’s what you called it, through the included power cable that has been cut. For the driver station I do not have a photo right now, but I will tell you that usually we get 70% packet loss for the first 10 seconds or so and then it holds steady around 20% loss. This does not change based on router.
We have ID’ed each Talon properly, many times. If we had any conflicts then they would be flashing red. We should probably try connecting the roboRIO WebDashboard through WiFi, but have not done so yet.
And to all people trying to help, just to be clear: all Talons work when tethered through USB. It is only over WiFi that 6 out of 14 Talons will stay blinking while Teleop is enabled, the other 8 turn solid and will drive.
Thanks for all the help.

Your computer should not have to install any drivers to get working with the ethernet. If it does you should install the drivers for your ethernet adapter or get a working usb ethernet dongle.

If you are having issues with your ethernet port, you will need to get them fixed, or you will not be able to control your robot because you will not be able to connect to the field at competition.

There are drivers for the roboRIO that need to be installed. They will not install through Ethernet.

That’s because they are USB drivers. They don’t have anything to do with Ethernet.

Oh! I just remembered what we figured out yesterday! The only Talons that enable during the Teleop over WiFi were the ones used in a command that is set as a default command. We have verified this by changing the default commands and the Talons do switch around. But for us this is not feasible as then the only command for an elevator moves it up and we can’t have it constantly moving up.

UPDATE: We figured out that if we connect to the robot, go to the DriverStation and click “Restart Robot Code” all the Talons will enable!

This seems like a programming problem then.

Just like PWM, you need to tell every speed controller what speed it should be running at all the time. Even if the speed is zero, you are responsible for continuously updating every speed controller.

We tried this. It did not fix anything, but the way we did it with the button is good enough. Turns out even if they don’t say that they’re enabled they still drive the motor.