Problem with the 2005 controller

Hi again…

I’m faced with a very strange problem. We have built a new driving system and we want to check it. For that I took the 2005 robot controller and hooked it up to all the necessary things. I downloaded a program to see that it works properly with the RC. The weird thing was that The radio receiver stayed in STANDBY state, and wasn’t working properly. I thought it could be that the receiver or the program has some sort of a malfunction, but when I connected the receiver to the 2006 controller it was working fine, with the program I tried to download to the 2005 controller.

I then noticed that there was another problem with the controller. It looked as if it were stuck at programming mode. The Program State LED did not blink and stayed orange, and the 3 lower LEDs were not blinking nor making any light at all. I think there is something wrong with the controller itself.

Has any of you faced such problem before? Is there any solution to it?

Thanks,
Guy

Did you have it teathered when you first downloaded the program?

Sounds like the OI and RC are set to different channels. Teather the controller then try it.
It could also be a code error. “If you get the red light of death” check to see if you have the correct library file.

Hope this helps.
**
200th Post!!:smiley: :smiley: **

The code has certainly no problem because it worked on the 2006 controller. I’ll try to tether it to see if it helps. Another thing I noticed was that when I pressed the RESET button, it was as if I pressed the PROG button, meaning that the controller was initialized after I pressed RESET

Are you aware that the 2005 and 2006 Robot Controllers use different microprocessors? If you’re trying to run a 2006 program on a 2005 controller, it’s quite reasonable for it to get confused. You should probably recompile the code with the proper library file and appropriate target CPU selected.

From the Using_Last_Years_FRC.txt file included with the 2006 default code:

To compile this project to work with your 2005 FRC (18F8520) system do the following:

  1.  Select the correct device from the MPLAB IDE. 

      Configure->Select Device->PIC18F8520

  2.  Replace the library file with the appropriate one.

      Remove the FRC_Library.lib file and replace it with FRC_Library_8520.lib
       
                                        or

      Remove the FRC_alltimers.lib file and replace it with FRC_alltimers_8520.lib

  3.  Remove the 18f8722.lkr file and replace it with the 18f8520.lkr file

  4.  Rebuild your project and download the HEX file to your controller.

This might be the solution to my problem. I’ll do that on Sunday when I get to see the controller again.
Thanks.

Yes today i had the same situation! … thats what i thought… something wrong with the MPLAB hex file created… worked with other controllers but that 1:(

I switched the files, but still, it didn’t make any change. The controller still seemed to be stuck and the LEDs weren’t blinking. Do you know what could possibly cause it?

Tether the RC and OI. Plug the OI into the wall. Download the default code. Check the OI dashboard (set OI to RC mode). Does the 2005 default code work? Do any errors appear on the dashboard?

If that works, try again with your program recompiled for 2005. Does your code work? Do any errors appear on the dashboard?

Is it just me, or does this seem to be a recurring problem?

Also you might want to try a master reset. This disables the user processor and allows you to download programs in the event of a problem preventing the user processor from accepting downloads normally. If you can’t get the light out of program mode you could have this issue.

Hold down both RESET and PROG buttons for ten seconds. Then release RESET and hold PROG for another ten seconds, then release. It should result in a power light, and an orange program light and nothing else. I think. It’s been a while, if that doesn’t work, trying releasing PROG after ten seconds and holding RESET for ten more, it’s one of those two I think :slight_smile:

Thank you so much! It really helped and solved my problem.
I pressed RESET and PROG for 10 sec and than continued to press RESET for 10 more and than all the LEDs returned to blink normally.

Thanks,
Guy