Problems connecting to limelight over FMS

Hi!

Sadly, during our last 2 events we have not been able to access our limelight 2 feed or receive data from it on the field. However, we were able to access it all through testing and in the pits when connecting the limelight straight to a laptop via Ethernet.

We tried several different troubleshooting steps recommended by the FTA and limelight docs which weren’t able to resolve the issue (http://docs.limelightvision.io/en/latest/best_practices.html):

  • Set both driver station and limelight to a static ip
  • Set both driver station and limelight to dynamic ips
  • reflashed with latest firmware
  • Powered limelight after connecting to rio
  • tried various subnet masks

Has anyone else had similar issues or have any suggestions??

Thanks!!

I assume you are running Limelight version 6.1 or higher?
Make sure the bandwidth in the pits is under 3 Mbps?

You can try not connecting your DS laptop to the field Ethernet until your robot radio (and the rest of it of course) has completed booting.

I’d stick with static ips on Limelight, roboRIO, and DS laptop.

Tried swapping radios? Adding an Ethernet switch? Setting Rio to static?

How is your robot network wired? Are you connecting it to the second port on the radio or through a switch?

We were able to get 2x Limelights working without issue with the following configuration:

  • DS Laptop IP statically on 10.XX.XX.5 netmask 255.0.0.0. All adapters except for the Ethernet port disabled in “Control Panel -> Network and Sharing Center -> Change adapter settings”.
  • RIO IP statically on 10.XX.XX.2 netmask 255.255.255.0
  • Limelights IP statically on 10.XX.XX.8 and 10.XX.XX.9 netmasks 255.255.255.0
  • Limelights stream rate set to “Low”
  • Radio “18-24V POE” Port -> 5-Port Unmanaged Switch -> RIO/Limelights/DS Tether
  • Radio “802.3af POE” Port -> Unused

Currently, we are connecting to the second port on the radio to the limelight and powering it separately (we are not using POE for the limelight). Our network setting and ips were pretty much configured the same, we can try to see if using POE with a switch will work. Thanks so much!