Problems Downloading Java (New Version?)

Hi -

A couple of weeks ago, I downloaded the Java JRE for the roboRIO with no problems. I just tried again last night with our second unit, and can’t get it to work. I tried with two different laptops and two different Internet connections (at school and at home) and both last night and this morning. It comes up with a constant checksum error (see log from the installer below). The computed hash is always the same - so I don’t think it’s a problem with the downloaded file being randomly corrupted.

I didn’t write down the version from before, but it is now Java 8 Update 33 (and I’m wondering if the installer hasn’t caught up)?

This is what is available for download: ARMv5/ARMv6/ARMv7 Linux - SoftFP ABI, Little Endian3 in the file: ejdk-8u33-fcs-linux-arm-sflt.tar.gz. It also doesn’t seem to quite give the same choices as the documentation (page 179 of the WPI docs).

I can go directly to Oracle and download it, but I’m guessing there is no checksum validation as part of the direct download.

Here is the link to the release notes on Oracle:

Is anyone else having this problem? Can I just go with using the external download? Or can you tell me what I am doing wrong? Like I said, I had no problems a couple of weeks ago after kick-off.

Thanks in advance!

21/Jan/2015 06:05:22,144- DownloadController: Signed in and have the .tar.gz link.
21/Jan/2015 06:05:22,313- DownloadProgressController: Initial url is
21/Jan/2015 06:05:22,462- DownloadController: Loading unknown page
21/Jan/2015 06:05:22,551- DownloadProgressController: Final url is
21/Jan/2015 06:05:22,553- DownloadProgressController: Starting JRE download. File size is 105920513 bytes
21/Jan/2015 06:05:58,287- DownloadProgressController: Downloaded JRE
21/Jan/2015 06:05:58,332- MainApp: Found JRE, checking hash
21/Jan/2015 06:05:59,618- MainApp: Computed hash is 28DDCAFE18C94BC019DA2FD99A111E1D, official hash is 082F08397B0D3F63844AB472B5111C8C

This appears to be a bug, Oracle seems to have changed the download URL on us when they updated to 8u33. This was released yesterday, we are using the previous version 8u6. Further, the archive page to the old version seems to be 404’ing. I’ll try to get this patched ASAP, but if you need to install Java within the next day, you can download it manually and run the JRECreate program with these options:

private static String] JRE_CREATE_COMMAND = {"java",
            "--dest", "JRE",
            "--profile", "compact2",
            "--vm", "client",

Put the created JRE folder in /usr/local/FRC/jre. You can’t just run the installer with your downloaded JRE file, it md5’s that as well.

Joe Ross pointed out another way to get the download working that allows you to download the original version and use the installer for the second half:

Here’s a procedure that should get the old version, at least until oracle stops hosting it:

In a browser, go to and download ejdk-
8u33-fcs-linux-arm-sflt.tar.gz. This makes sure all the right cookies and logins are set up.
Then go to the following link to download the old version:

Once you have 8u6 downloaded, you can just point the installer at it and go from there.

Fred & Joe -

Thank you very much for your prompt response on this … I was able to get the right file testing it here at work; hopefully the link will still be there tonight when I get to build.

Although it is perhaps obvious to everyone else - you might consider adding a note in the documentation about how the version of Java you use for FRC is constrained, and one shouldn’t see a new release and go try to download and use it … one of the downsides of opening up the platform (Linux & Java) … although I am not complaining!

Thanks again!

Yep, Kevin updated the documentation this morning. Thanks for letting us know!