Problems reimaging cRIO

I’ve made it up to the point where I need to reimage the cRIO. I have the updated code on my laptop. I have the orange cross over cable directly from my laptop to the cRIO port 1. (I’ve also tried every other possible connection there is and no difference). Static IP set to 10.14.44.6 mask 255.0.0.0

The FRC cRIO Imaging Tool opens and sees the cRIO as 10.14.44.2
When the imaging tool tryes to connect it give me the error “The specified IP address is unreachable. Ensure that the IP address is on the correct subnet.”
I’ve disbled the PC firewall and disconnected from the wireless network.

I have been able to connect a few times after reconfiguring/reseting. Don’t know why. The reimaging gets started but then I get an undexpected error 60. The next time I try, I’m back to the first problem.

Any advice?

See if this works: http://www.chiefdelphi.com/forums/showpost.php?p=785938&postcount=17

Ravena,

When we imaged the cRIO, we didn’t use the crossover cable and we left it plugged into the the webcam. We then took an ethernet cable from port 1 on the cRIO to one of the ports on the driver station. Then, and ethernet cable from the other port on the driver station into the laptop. Power on both devices, driver station and cRIO.

Your laptops static IP should be set to 10.0.0.6, and NOT the IP with your team #. I’m not sure how your teams number would already be in the cRIO if this is first time you have imaged the cRIO. When you open the cRIO imaging tool, the “current IP” will be in the far left column of the device table. The subnet mask should be set to 255.0.0.0

Also try another computer. We had all kinds of headaches that went away when we switched to another computer.

I totally agree with Hadi379…we had the same problem and i believe by changing the ip address it fixed the re-imaging issue

good luck!

Thanks to everyone who replied.

Here is where I am at:
-It seems like when I tried the reimage, the IP address of the cRIO got set at some point in one of the trys. I was able to ping it using 10.14.44.2.
-I tryed using the Measurement and Automation utility and it found the cRIO and also said the IP was 10.14.44.2. I was able to change Development Environments but not reimage, so I am talking to the cRIO.
-I tryed a different computer (set to 10.14.44.6) and it worked. I found later that the computer that worked had update FRCLabVIEWUpdate1.0 instead of 2.0. Now I’m afraid to upgrade to 2.0.

When we switched computers and the reimaging started working, we had the 2.0 upgrade, so it seems that switching computers has helped in more than one instance.

Sure wish we had a definitive reason why a computer switch seems to clear up this problem.

I tryed again today with my new laptop to reimage the cRIO and same problems.

I upgraded my standard computer to FRCLabVIEWUpdate2.0.zip and it reimaged the cRIO just fine. ??? Only difference is laptop is Vista and standard computer is Win XP.

???

go into network connections and go to the properties and then change the ip address for the port and then it should read it. Then reset it with the imaging tool and then you are all set… if you still cant get it i can make a video or something…

We’re also having problems. PC is set to 10.0.0.6 and plugged into Ethernet 1 on the cRIO via a crossover cable. I can ping 10.0.0.2 but the cRIO imaging tool tells me no cRIO found. This is our first attempt after trying out all of the initial bench tests - we haven’t communicated with the cRIO before.

Problem resolved - disabling all other networks on the PC seemed to help the most. Was also able to see cRIO in MAX and originally changed IP address there.:slight_smile:

Should we need to continue reimaging our cRIO every time we want to download code? Our driver’s station doesn’t work unless we reimage the cRIO but we were unsure if this was a normal problem.

You should only have to reimage the cRIO once with an update. The image then remains in nonvolatile memory. You have to use the same reimaging tool to switch between booting to C or booting to LabView, but that is only the check box at the top of the tool. You do not have to reimage.

Tony

Looks like this problem has been fixed with the FIRST Robotics Competition Software 2009 Update 3
Readme file states:
Bug Fixes

  • Fixed an issue in which running the CompactRIO Imaging Tool on Windows Vista returns unexpected error 60.

My Vista laptop worked fine with this update.