Problems with Cypress board

I wired the Cypress board digital input/outputs to buttons (ex. P4_4 being digital input one). On the inhanced i/o configuration it is configured to “input (pulled high)”. I wired P4_4 to ground when the button is pushed. I would think that when i push the button it would go to ground and turn on the light for digital one on the inhanced digital i/o section of the drive staion, but it doesn’t, any suggestions?

Is the Driver Station recognizing the Cypress board?

  • Is there a green light on the I/O tab?
    *]Does the Diagnostics tab have a green light next to I/O?
    Your expectations are correct, by-the-way.

Be careful with the Cypress board. I spent a lot of time last year and was extremely frustrated with it’s performance. It never seemed to work right for me - but, maybe it’s better this year or the drivers have been re-written

Anyway, if I can remember correctly from last year, check to see if the inputs are read only during startup.

Good luck, but my advice is to stay away and try to wire directly into the crIO.

Actually, I think it would be normally ON and turn OFF when you pressed the button, assuming ON corresponds to Vcc and OFF corresponds to GND.

That’s how it worked for us last year.

Not sure I understand your reasoning here, the Cypress board is for the Driver Station computer to read inputs such as buttons, switches and potentiometers. It’s not for use on the robot or in conjunction with the cRio. I’m not even sure how you’d hook it up to the cRio without a USB host on it.

Matt

We can’t even see ours when it’s plugged into the driver station. One of our mentors has gotten the Cyprus board to work on his laptop and he can read the button inputs we have on it, but it doesn’t recognize the board on any of our team’s laptops.

Is there a simple fix to this, besides doing a complete re-install of the DS and the Cyprus bundle? Or is there something we’re not doing right?

We went through this exact situation this weekend. One laptop could talk to the Cypress board fine, the other could not. Reinstalling the DS software (and only that, we didn’t mess with anything else) caused it to work. My guess would be a corrupt/stale config file somewhere. It doesn’t take too long to reinstall the DS software, probably less time than it would take to fully debug this issue.

Good luck,
Matt

I think you have to log in with the board plugged in. We had problems with this last year (yes, during competition…)

On the computer it worked on, we hotplugged it after that computer had been running for days and it worked fine, after a DS reinstall on the programming laptop it also worked there as well.

Good thought, but it doesn’t seem to matter if you log on with or without it.

Note that the Cypress used is specially imaged with FIRST specific drivers and likely is not recognizable by other software.

We are trying to connect switches to the Cypress board as described above. The first 4 digital inputs work beautifully, but the others don’t. They seem to lag significantly when they work, but sometimes don’t work at all.

The digital pins are labelled with different functions on the pinout diagrams, and I’m wondering if that is the problem, or a connection problem.

We are currently using the breadboard, but we may try something different for connections.