Problems with Setting Up Alternate Driver Station

I’m from rookie team 6662 and for the most of the build season we have been using the Lenovo ideapad that came with our KOP. However that computer is pretty terrible (in terms of speed and screen size), so we’d like to turn my HP Envy into the Driver Station. The Ideapad has connected to the robot and worked fine throughout the build season, but the Envy is having problems.

The Envy works when tethered with the USB A Male to B Male cord, but the SmartDashboard doesn’t open manually and when opened automatically doesn’t display any of the values. Also, although the computer connects to the Wifi and is assigned an IP, the communication indicator in the driver station is red. Under diagnostics, the robot radio light is green but the roborio light is off. I redownloaded all the National Instruments Software a couple days ago, but I’m willing to try that again. Firewall is off. The roborio firmware is only on the second update (which came out a week after kickoff), but I’m fearful of updating it today because connection issues could ruin any practice we have.

It would be great to get the driver station and smartdashboard working on this computer because it is significantly faster.

Thanks for the help.
Team 6662

We’ve used many different computers to control our robots over the years, so model/make shouldn’t be an issue.

With the current control system you don’t need to set the IP on the computer for wifi (unless I’m mistaken). Did you make sure the old Lenovo isn’t still trying to connect?

Did you make sure to set your team number in the driver station settings on the Envy?

The team number is set correctly. When I mentioned the IP I was just saying that we were connected to the robot radio network; the IP was automatically assigned. The problems persist when the Lenovo is powered off. I have tried pinging the roboRIO as described in this Screensteps page but the ping request can’t find the host, even though the firewall is off. I can ping the radio however.

Make sure you are up-to-date with all the Windows patches on your computer.
Apply all the FIRST updates as well.

It sounds like you are using the wireless to connect to the radio, but cannot see the roborio.
Make sure that the team number of your roborio matches the team number in the driverstation.

Can you tether with ethernet your laptop directly to the roborio and see it in the driver station?
Can you then tether your laptop to the radio and still see the roborio?