Problems with solenoids

Hello there!

Recently we have been working on pneumatics, and unfortunately we are having trouble getting our solenoids to work. When it is activated with the controller, our CTRE PCM lights up beneath the port where the solenoid is connected, and the solenoid makes a clicking sound, however the air does not switch sides. We made sure the voltage is right by switching the jumper on the PCM (we are using a 12v solenoid, also we tried switching to 24v and tried with a 24v solenoid, but it didn’t work as well). We also tried updating the firmware of the PCM as says to do in the pneumatics troubleshooting section. Any tips or suggestions on how to get it working? Seems weird that two different solenoids would be broken.


Sounds like you have done most things right.

Can you share a picture of the setup?

What input pressure are you providing to the solenoid? Are they single or double solenoids?

Edit: This seems similar to this thread:

1 Like

Photo of the setup attached, using a single solenoid and supplying 30 psi when trying to activate it. Also this morning we tried using a new PCM, and it didn’t work as well :smiling_face_with_tear:

That solenoid valve is a 24V model, but your PCM is set to 12V. Change the jumper in the middle to 24V

Edit: I’m dumb and can’t read… nvm

Your photos show 12VDC solenoid and 12V PCM so that should be okay.

Not sure what you meant when you say a couple of times “didn’t work as well” since most of these states are either working or not working with little “sort of working” possible.

There may be a problem with your CAN topology but if the lights on the PCM change as expected then that’s not an issue for this testing.

If you’ve tried multiple PCMs and multiple solenoid valves it’s unlikely but still possible multiple components have failed.

I’d like to nail down a couple of ambiguous statements.

  1. you say you pressurized to 30 psi. That is well above that solenoids minimum of 21 psi but maybe your gauge isn’t accurate that low. Try a higher pressure to make sure. (Always wear your safety glasses!)

  2. You say “air does not switch sides” and I don’t know for sure what your expectations are so that could be clarified as to what you want for flow paths energized and de-energized.

There is the possibility of swarf or other dirt causing trouble.

If everything is perfect except for the invisible, then start by making sure the manual override red button isn’t stuck.

You can remove the solenoid and make sure the manual spring isn’t sticking, the piston isn’t sticking, and the return springs are all functioning.

My team doesn’t use that model of valve so I can’t guess well what to expect if you open it up. (Don’t lose the springs.)

Summary - before tearing apart the valve and if the PCM lights are correct then give the system higher operating pressure and make sure you understand what the flow paths are supposed to be. I’d also make sure I have a properly plumbed cylinder on to make sure the back-pressures are right.

I would screw the snubber on the R port all the way out. Try pressing the manual button on the valve body. Some valves let you lock the manual button on. Been there done that If the led under the port turns on when the soleniod is “energized” then the software and can is working

Okay so we ended getting it up working. Kind of an embarrassing mistake—we never bothered to actually hook the solenoid up to the piston, and when we did it immediately started working :melting_face:

Also we noticed we forgot to hook up the CAN wires to the PDB after checking it as @SLAB-Mr.Thomas suggested. Don’t think that actually was affecting it, but better to find this out now.

Thank you all again for your helpful tips and suggestions—really appreciate it!