Problems with the RSL

Hi
Our team was trying to connect the Signal light for 3 days with no success.
We searched on the web and found no answers.
we connected the signal light with 3 wires:

A wire connecting La and Lb
Lb—|
La—|

A wire connecting N and the negative on the sidecar
N-----------(RSL negative on the sidecar)

A wire connecting La and the positive on the sidecar
La----------(RSL positive on the sidecar)

Our signal light is not responding when we turn on our robot, neither the LEDs next to the RSL conncetion on the sidecar.
We will appreciate the help.

Team #1943

Connect the RSL exactly as shown on the Power Distribution Diagram and it should work fine.

Regards,

Mike

Your description of your connections sounds consistent with the Power Distribution Diagram.

Here are a few things to check on:

  1. Is the Digital Sidecar properly connected to the Power Distribution Board? Make sure the Power, 5V, and 6V LEDs light up when power is applied. Make sure that the Wago terminals on the Power Distribution Board and the Digital Sidecar are grabbing the wire and not the insulation, If the wire is not stripped long enough the terminals can grab the insulation.

  2. Is the Digital Sidecar connected to the cRIO with the 37 pin cable?

  3. Did you try the other Digital Sidecar to verify it is not a hardware problem with the one you are using?

It’s not your wiring of the RSL that’s a problem. The RSL just repeats what the LED beside the RSL connector is doing, and if it’s never on, then the RSL shouldn’t be on either.

Something to add to the checklist.
-Is your module that the Digital Sidecar is connected to in slot 4 (slot 6 doesn’t use the RSL)?
-Have you re-imaged your cRIO with the latest v11 contained in Update 3a (the OTB version doesn’t use the RSL)?
-Check your other indicators for clues, such as the Driver Station Battery status.

I’m pretty sure Vikesrock meant the white Wago connector that brings 12v power to the Digital Sidecar in #2 above, not the RSL connector which is a standard 2-pin .1" header.

Thanks Mark, I must have gotten a bit mixed up when I was writing that post. I went back and edited it so it should be correct now.

To Vikesrock:
-The digital sidecar is connected properly and everything except the RSL works perfectly.
-The RSL terminals are grabbing the wire and not the insulation
-We have tried the other sidecar

To Mark McLeod:
-Our module is connected to slot 6, does it matter?
-Our cRIO is updated
-The white wago is connected properly

Disconnect the RSL and see if the LED next to its connector lights. You might have a short somewhere.

Try enabling a relay - they are on the same chain as the RSL, and they have indicator LEDs.

Bingo.
Slot 6 does not use the RSL, so it will be off all the time.

Your module must be in slot 4 to play.

And you can call me Mark, we’re colleagues :slight_smile:

Thanks Mark!
It works now, i can’t belive how simple the problem was.

Our signal light does not work either. I have a voltage reading on the terminals of the light, but no blinky-flashy

Any ideas?

Have you checked your wiring per the Power Distribution Diagram? (link in one of the above posts)

If you’ve got voltage on the RSL output, there’s no reason for no light other than bad wiring or broken light. You could also plug it into a 20A breaker to confirm the wiring.

Russ

I will try these ideas and see what happens. What do we do if we have a bad light?

dumb question, but what type of connector do we use on the digital side car for the rsl light, what is

standard 2-pin .1" header??

did it come in the kop??

doesn’t look like a wago style on the side car

thanks in advance

In this photo of the Control System parts: http://www.chiefdelphi.com/media/img…d504b545_l.jpg

They are the coiled grey cables all the way to the bottom right.
They have 2-pinconnectors at either end. Cutting them in half gets us two connections.