Project Type not showing up on Eclipse, Help!!!

When I go to create a new java robot project, I’m unable to select my project type, What is going on??? I need to be able to at times select Iterative Robot and at times select command base, but I never get these option, some weird TimedRobot type thing is appearing. HELP!! I run Linux also,

Strange. Have you checked the eclipse error log (Window-> Show View -> Other -> Error Log)? Clear the log, attempt to create a new project, and see if a new error occurs.

If you can extract an error message there, entering an issue on the allwpilib github issues list with the details may get you more direct help.

Timed robot is one of the new options this year. It’s actually what we’re using, but that’s probably for a different thread…

Did you go in the button New, and New Project… and there it is the WPILib Robot Java… but if you dont have this option probably you dont have the plugin

Exactly - you should first check to make sure Eclipse has the WPILib plugins. There are several clues on this, including the presence of a WPILib menu item, jar and utility files located in C:/users/<username>/wpilib. If these are not present, you don’t have the plugin - follow the screenstepslive procedure to install the WPIlib plugins.

If you do have the plugins, then something might be messed up with the configuration. You can always blow away your eclipse installation and start over, that tends to fix any quirks (you start from a known-good baseline).

One more thing - I believe you need no earlier than the Oxygen release of Eclipse (problems with older versions). Has it ever worked (this year) with your eclipse installation?