Prusa i3 MK3i layer shifting issue

So we’ve been encountering a problem with one of our prusa i3 MK3i’s for …like a year now, in which there’s rather horrible layer shifting. Today’s most recent example:



PLA, default settings for print speeds

Things we’ve tried:

  • rebuilding the hotend
  • adjusting belt tension both up and down
  • rebuilding the x axis
  • adding lubricant
  • replacing the bearings

It hasn’t gone away. Some interesting things of note is that it always seems to happen around the same spot ~15 layers up or so. however, i’ve also ran a test print of a really small pillar that went up past the z-level it typically happened with no issues.

Ordinarily, I’d say the belts. but, seeing as you’ve dissected that…

Check the Z axis carefully. You’re looking for straight tracking, or dings in the axis.

Also check the G-code. It may be that something is being added somewhere to shift a layer.

2 Likes

The rods can get scored also, be sure to check them out.

1 Like

Is the printer in stealth mode? usually it would detect a layer shift and rehome, but thats disabled in stealth mode.

You should also debug bearing tension (from surrounding hardware) and verify theres no scoring in the rails. I’ve also seen prusa bearings fail from not being re lubricated.

1 Like

no

The x and z axes both look fine, there aren’t any nicks that I can see

Additional context regarding the above image, I was watching the print when the layer shifting happened, and it didn’t seem like anything was off.

I solved this problem with my Creality printer once by adjusting the wire management… at a certain height, the wire sleeve was catching behind the printer sometimes and could catch enough to cause the shift. This was an abrupt rather than gradual shift, so I’m not sure this could be your problem, but seems worth mentioning.

2 Likes

I did have to replace a Y-motor on a MK2.5 because of layer shift issues.

I assume you’ve already found resources like:

One other suggestion I’d have is to check that the print head cable bundle isn’t catching on something when it reaches a certain height.

1 Like

Are you running from octoprint/a computer or from SD? In the past I’ve had a number of layer shifting issues when printing over USB through octoprint that went away when I switched to using an SD card. It seemed especially common with small round objects which would have many g-code commands of linear movements to form the arcs.

2 Likes

I think the prusa can only run from SD card.

Some more images:
the entire printer:

it’s repeatable


until somehow it isn’t

I don’t think anything catches on anything, I’ve watched the print shift without seeing anything immediately sus.

I also don’t think it’s the gcode’s fault (but not too sure on that); this problem has followed us across slicers - Cura to prusaslicer

Though this iteration of the issue is a bit different from before - before it was an abrupt shift of a few layers of ~3mm and then back to it’s original, repeatedly

Hey! I’ve built a rep rap so I am familiar with all failure modes of 3d printers! This is probably one of three things, stepper is getting too hot and skipping steps (probably not). The stepper driver is getting too hot and shutting off (maybe), or most likely, your stepper current is too low, try adjusting the potentiometer on your main board, clockwise is usually more current. Best of luck, if that does not work it is a loose connection to the stepper. I have had this problem before, let me know if that fixes it!

1 Like

Ps. Prjsa can print over USB (it runs Marlin 2.1.1) so repiteir host can print to it over USB!

2 Likes

I’m pretty sure prusa uses Polulu stepper drivers which can have step dropping problems.

I run my Prusa from Octopi connected to the USB B. I can upload gcode directly from PrusaSlicer without even being in the same room.

1 Like

where potentiometer

1 Like

For what it’s worth, Prusa support is extremely responsive and knowledgeable and has helped me a number of times. Definitely worth contacting them if you haven’t already.

2 Likes

The prusa mk3 has trinamic stepper drivers and there are no potentiometers to turn on the board.

@RisenFalcon I would ask on the prusa forum, they are very familiar with these machines.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.