PSoC isn't connecting to new driverstation laptop

We bought a new driver station laptop. When we tried to connect the psoc to it, it didn’t connect at all. The connection light on the psoc was green, and it’s connected directly to the laptop. I tried installing the psoc software from the dvd, but that didn’t do anything. Also, for some reason, the psoc auto connects to my friends laptop with no problem.

(http://fc06.deviantart.net/fs71/i/2011/101/2/a/scared_derpy_by_blackm3sh-d3drw8d.png)

Installing the DVD from the Cypress case has pretty much messed things up now, whatever was wrong before.

You’ll need to uninstall all that software and reinstall the PSoC FRC-specific software from the Driver Station Update.

Do I have to uninstall everything that came with the DVD’s or just the drivers?
Also, where would I get the FRC specific software?

The FRC Updates are found at the bottom of this page: http://www.usfirst.org/roboticsprograms/frc/2012-kit-of-parts-control-system

You’ll need to uninstall everything Cypress.

It’s still not working. The PSoC is connected to a button, and this button lights up when there is power to it. It has light on my friends laptop but it has no light on the driver station. I tried connecting the PSoC through all ports available in the driver station, both directly and indirectly, but alas no bank.

Bump

Check if the CyMiniProg3Service is running:Start -> Control Panel -> Administrative Tools -> ServicesDid you run any online updates? Don’t do that.

You can check the Cypress versions:
Cypress PC program – Start->Programs->Cypress->PSoC Programmer 3.12

  • Driver Station Install 3.12.0.827 (correct version)
  • Update from Online 3.12.4+ (user did an online update - incorrect)
  • Cypress DVD case 3.10.0.440 (user installed the Cypress DVD – incorrect)
    If none of this yields results, then I’d recommend as a last resort:
  1. Uninstalling all Cypress software again, including Programmer, Creator, and the drivers, too.

  2. Uninstalling the Driver Station software too (can be done with the DS installer linked earlier).

  3. Edit the system registry and remove all references of cyminiprog3

  • Start->Run
  • Regedit
  • Find “cyminiprog3”
  • Delete what you find
  1. Edit the system registry and remove hklm/software/cypress key

  2. Restart computer and verify that cyminiprog3 service is not listed in service manager

  3. Reinstall Driver Station update. This time all sections should be listed for install (PSoC and Driver station)

  4. Check PSOC by plugging it into USB and pressing the button. Light 2 will light if the PSOC has V2 of the firmware install. If you don’t get light 2 Run the programmer app and load FRC_IO.V2.hex onto the device.

  5. Start Driver Station. Driver station should now see PSOC device. If not verify that miniprog3 service did start (may need to start service manually in service manager window).

I don’t want to make you panic, but…

Last year I made the same mistake you did. I removed all references to Cypress EXCEPT in the regedit. (I didn’t even know that it existed then). I ended up reflashing the DS, reran all updates W/O installing the DVD from USB, and it worked good.

Took me three hours then. Three good hours of sleep, gone. But amazingly, the code worked properly the first time through. (whaaaa?)

So therefore, chances are, read everything before installing software. It’s a painful road that many have traveled before, including me.

But then this brings up another question: Why doesn’t it work with the DVD installed?

We have experienced a lot of problems with the psoc, including but not limited to; twitching robot, loss of control, etc. I strongly suggest moving to an alternate control interface. Below are some of the products we have switched to: