Pushing down LabView Code

After we push down labview code to the crio, we get a NO CODE message at the battery display on the driver station. We are using the cross over cable and going straight from the laptop to the crio. The laptop recognizes the crio and gives no error. When we disconnect from the crio and reconnect it to the driver station the NO Code appears. We have set the ip addresses correctly and installed the update 2 from national instruments

Do we have push down code thru the driver station with the laptop??

Hey, when you download your code to the crio and that finishes, press the restart button on the crio so it can reboot. See if that helps,

Alex

tried powering down both the crio and the driver’s station, didn’t help, any more suggestion??

Why are you swapping cables and connecting directly to the cRIO? Is one of the ethernet ports on your Driver Station broken?

Did you change the build specifications on your LabVIEW project to make it run as startup?

no we don’t think we have a problem with the driver’s station, it seemed simplier to go straight to the crio, but is that the problem, does the code have to be pushed from the laptop thru the driver’s station to the crio??

and no we didn’t change the build spec, we are pushing with the deploy option, will that work??

You don’t have to push the code through the Driver Station. It doesn’t need to know.

You can also bypass the DS by connecting your laptop directly to the router rather than directly to the cRIO.
Typically though, you want to get used to connecting your laptop to the DS, because the router won’t be available at competitions and it’s so much easier to run over the wireless system when you’re developing code at home, rather than to connect your PC directly to the cRIO.

The “No Code” means there’s a disconnect between the DS and cRIO, but they have established basic communications. The code that sends the battery voltage is just not running on the cRIO.

–When you first flash the cRIO (with v7 from Update 2) there is code left to run and return the voltage.

–When you “Run as startup” to deploy new code, you need to reboot the cRIO afterwards to have it actually start.

–If you use the “Run” button to test code, under certain circumstances that will disable any pre-existing code on the cRIO set to run at startup. You will need to redeploy using “Run as startup” again.

It sounds as if you missed a step in deploying your code, so that it’s on the cRIO but not set to run at startup.

No, simply deploying it will not work.

Under “Build Specifications” under the cRIO project file listing, right click and create new build specifications. The only thing our team had to change was adding Robot Main to the startup VIs list (though some other settings may have also changed, check the documentation for correct settings).
After that, you must first right click the build spec and select “build,” then when that is done “run as startup.” This will build the code, then deploy it onto the cRIO and run it as the startup code.

Also, when you turn on the DS, it will usually cycle through “No comms,” then “No Code,” then it will display the voltage and be ready for use.