Radio Configuration Issues

I’m trying to set up a radio using the latest radio config utility, but it isn’t letting me configure it. I was able to load the firmware, but when I hit the configure button, it says “Bridge configuration failed:Failed to change IP address, please ensure the bridge is connected to this computer and try again”. I’ve tried all the troubleshooting tips that I’ve seen, like disabling all of the other network adapters, making sure the ethernet is in the correct port, and manually setting the IP address of the network adapter, but nothing has worked. If anyone has had this problem and knows how to fix it, I would really appreciate your help!

1 Like

On the radio, use the Ethernet port closest to the power plug. After you do the firmware update, power cycle the radio. Wait 2 minutes after you reapply power – these take a long time to boot up. Then, restart the configuration process. It should find the radio and be fine from there. Many times, the firmware update isn’t needed, it’s just that the radio hasn’t come up all the way and the utility finds it still in the bootloader, or resets it and catches it there. Generally speaking, if you can do the firmware, you should be able to get it configured. The timing tends to mess things up though.

1 Like

Thanks for the tip! I just tried waiting longer, but it didn’t seem to do anything - I’m still getting the same error that I did before. Is there something else I might be missing?

1 Like

If you have not been using this, go ahead and follow those steps exactly. Then, tell us what the LEDs on the radio are doing and get some info from the PC you are using by running “ipconfig /all” (instructions here). Posting a picture of the error message might also be helpful.

These kinds of problems are harder to work remotely – sorry for all the back-and-forth.

If you know how, go ahead and do “ping /n 5 10.<TE>.<AM>.1” and “ping /n 5 192.168.1.1

1 Like

Yeah, I’ve been using those instructions. The power LED is going solid when I plug it in, then blinking for a few seconds, then staying solid. The light on the port the ethernet is plugged into is sometimes blinking, sometimes solid, but never blinking in any regular pattern. Both the other lights are always off. The output from ipconfig is:

Windows IP Configuration

Host Name . . . . . . . . . . . . : DESKTOP-N47JLVA
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Robot:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek USB GbE Family Controller
Physical Address. . . . . . . . . : 9C-EB-E8-D3-B7-92
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Thanks so much for your help by the way, I’ve been struggling with this for literally 8 hours now.

Sorry - that ipconfig is wrong!

Windows IP Configuration

Host Name . . . . . . . . . . . . : DESKTOP-N47JLVA
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet0:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) 82574L Gigabit Network Connection
Physical Address. . . . . . . . . : 00-0C-29-44-1D-94
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2604:3d09:e82:3900::f828(Preferred)
Lease Obtained. . . . . . . . . . : Monday, April 26, 2021 2:28:17 PM
Lease Expires . . . . . . . . . . : Monday, May 3, 2021 2:28:16 PM
IPv6 Address. . . . . . . . . . . : 2604:3d09:e82:3900:496f:aaab:a3aa:6fe4(Preferred)
Temporary IPv6 Address. . . . . . : 2604:3d09:e82:3900:248a:33af:a2c8:b43(Preferred)
Link-local IPv6 Address . . . . . : fe80::496f:aaab:a3aa:6fe4%12(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.51(Preferred)
Subnet Mask . . . . . . . . . . . : 255.0.0.0
Default Gateway . . . . . . . . . : fe80::226:86ff:feb1:a391%12
DHCPv6 IAID . . . . . . . . . . . : 100666409
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-28-17-89-69-00-0C-29-44-1D-94
DNS Servers . . . . . . . . . . . : 2001:4e8:0:4001::16
2001:4e8:0:4006::16
2001:4e8:0:4001::16
2001:4e8:0:4006::16
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Robot:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek USB GbE Family Controller
Physical Address. . . . . . . . . : 9C-EB-E8-D3-B7-92
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::515b:51f7:5be7:b8b5%7(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.184.181(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 480046056
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-28-17-89-69-00-0C-29-44-1D-94
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Is what one expects to see if nothing is plugged in, there’s a bad cable, or something similar. You won’t be able to get anything more by running ping, so don’t bother.

The firmware update goes through without issue? If you can, try a different cable – better still a different PC and cable if you have this. You can also try the other Ethernet port on the radio. Don’t do any more firmware updates though, just see if it will configure. If you have a second radio, you can try that. The idea is to eliminate things it could be, starting with the cable. It looks as though it could be some sort of hardware issue, these tests are meant to rule things in or out. Also look inside the Ethernet jacks on both ends, to see if there’s any visible damage.

Edit: just saw your updated ipconfig, will do another post…

1 Like

OK, you have two not-disabled Ethernet adapters. It looks as though your Internet connection is also using 192.168.1. (actually – this is probably from the config program messing with the wrong adapter), so that’s a likely source of trouble. You will loose Internet when you disable everything except for the Ethernet connection to the radio. Which version of Windows are you running? Here are instructions for Windows 10.

You could also try just plugging the radio into the other network!

1 Like

Unfortunately still not working - but here’s the new ipconfig:

Windows IP Configuration

Host Name . . . . . . . . . . . . : DESKTOP-N47JLVA
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Robot:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek USB GbE Family Controller
Physical Address. . . . . . . . . : 9C-EB-E8-D3-B7-92
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::515b:51f7:5be7:b8b5%7(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.184.181(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 480046056
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-28-17-89-69-00-0C-29-44-1D-94
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

That looks much better. Try restarting the utility and see if it will configure now. Did the utility give you a drop-down to choose the network adapter to use (before you disabled the other one)?

1 Like

Still not working. It does give me a drop down, and I had the right one selected - now there is only the one I had selected, but no luck.

Check the ipconfig again – it should have an “IPv4 Address” which is not “Autoconfiguration”.

Assuming it does not, there are a couple of things to try:

  1. Use the other network adaptor (disable the “Robot” one and reenable the one you had disabled, and plug into the other port);
  2. Reboot the PC, make sure the other adapter is disabled (just do the disable procedure again), and retry the configuration/
  3. Where are the two Ethernet ports? If one of them is plugged in via USB, unplug that one, reboot, and try just with the built-in Ethernet.

[In the ipconfig where it showed two Ethernet adapters, it actually looked as though the radio was talking to the adapter you disabled, so I think you may be plugged into that one. I just noticed this!]

1 Like

That ethernet port doesn’t actually exist, my computer is just a bit weird. Rebooting didn’t seem to make a difference, but here’s the new ipconfig:

Windows IP Configuration

Host Name . . . . . . . . . . . . : DESKTOP-N47JLVA
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Robot:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek USB GbE Family Controller
Physical Address. . . . . . . . . : 9C-EB-E8-D3-B7-92
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::515b:51f7:5be7:b8b5%7(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.51(Preferred)
Subnet Mask . . . . . . . . . . . : 255.0.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 480046056
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-28-17-89-69-00-0C-29-44-1D-94
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

1 Like

OK, this is looking pretty good… Try the “ping” commands (above), if things are still not working.

1 Like

The pings to 10.50.15.1 say “PING: transmit failed. general failure.”, but the pings to 192.168.1.1 go through.

1 Like

OK, that means the PC and the radio are communicating normally, but that the radio didn’t configure itself to also use the address it needs to use to do it’s job on the robot. Was the error from the configuration program the same as before? Now that there’s only one adapter and things are connected as expected, it’s worth going through the steps from the official instructions carefully. There was a problem that has been fixed – there could always be more than one problem to fix, but it’s worth double checking at this point.

Also, type 192.168.1.1 into your browser and let me know what happens.

1 Like

Yeah, still the same error after going through everything again. 192.168.1.1 in my browser just comes up with the usual “Unable to connect” screen.

This is a tough one. :frowning:

Try plugging into the other port on the radio and redoing the ping and the browser thing. If the browser pulls up a screen (from the radio), you should be able to configure at that point. If not, I’m down to desperation measures – all the usual things have been tried. What kind of PC do you have (mostly just out of curiosity but also grasping at straws)? Which version of Windows?

You can do ping 192.168.1.1 and just leave it run. You should see a difference when you plug and unplug the radio. This just confirms you really are in communication with the radio, which seems to almost be a given. You can run route PRINT and paste that output here, might have a clue there.

1 Like

Same response from the pings as before, and still no luck on the browser. I have an Asus Zenbook running Windows 10 - only a couple years old, so there shouldn’t be any problems there.

1 Like

Let’s see what “route PRINT” has to say. Your PC does not have a built-in Ethernet, but it seems to have enough of the hardware internally so that Windows is seeing one. You probably want to leave that disabled, it can’t work and will only cause confusion.

1 Like