Radio Firmware Upgrade Issue

We are unable to upgrade the firmware of our radio.
I have followed all of the steps in this link


Steps we have taken:
Laptop is running Windows 10 pro
Disabled the WiFI adapter in Control Panel
Rebooted the laptop multiple times
Ran the FRC Radio Configuration tool as Admin
Used two different ethernet cables.
No VPN on the laptop
Tried another laptop using Windows 10
Windows Firewall disabled

All tries find the radio after resetting power. Firmware upgrade starts
End up with “Bridge firmware load failed, Timeout Flashing radio. etc …”
Is anyone else running into this issue?

How long do you leave the radio powered before attempting to flash? You need to wait until it is completely powered up (about 45 seconds).

I’ve seen similar problems and could never figure out what the root cause was, but solved it by switching laptops. Tried 2 laptops, both without built-in ethernet. Used a USB-to-Ethernet converter that worked OK for connecting to for example the RIO from either laptop, but programming the radio was only possible with one laptop, not the other. Then used a laptop with built-in ethernet, and that was OK as well.

Make sure you have up to date ethernet or usb/thunderbolt to ethernet drivers depending on your setup.

At 2495 we kept an old laptop with a full size Ethernet port running Windows 7 for that purpose as we never managed to get the FRC Radio Configuration Utility properly working on our newest laptops running Windows 10…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.