Radio Lag / Randomly Dropping Communications


Our team is noticing a huge packet loss using the legal radio on our competition robot. On our practice robot (using last years radio) there are zero connection-related problems.

We are experiencing a huge amount of packet loss. Up to 25 packets per second over a 20 second time period, after which it will cool down and function normally. After a couple seconds the problems return, and we begin losing packets/comms again. What could cause something like this to happen?

Thanks in advance.

Might be conflict for the wireless channel that the DLink defaulted to.

You can try setting different channels in the DLink.
If you have a tool like Inssider, you can see what conflicts there are in the area.

We installed InSSIDer and took a look… nothing seems to be interfering.

To elaborate a little more, “Watchdog Not Fed” flashes occasionally when it lags out (not every time). Sometimes the Robot Code blip will turn off, sometimes the Communications will turn off, sometimes both will. It appears totally random. I’m not sure if this has anything to do with the root of the problem, but I thought I should mention it.

In practice at our school, we did not notice any problems.

We were at a practice site yesterday, and they had problems with the Field Management System, so all the teams switched to wifi direct connect. Most of the teams were experiencing the same problems you mentioned. At first, I thought everyone was saturating the wifi, but the problems persisted when:

  1. There were only two bots on the field; and
  2. The bot was at the loading station less than 5 feet away from the driver’s station.

This evening I will be checking the bot back at our school.

We have seen this more times than I’d like. We haven’t been able to find the route cause yet. It seems to get worse the longer the crio goes without a reboot. If it sits long enough the Robot Code drops out for good.

I wonder if it has something to do with the QOS settings that were added to the router configuration this year. Do you have a camera on the robot? Try disabling the video on your Dashboard and see if that helps.

That was the last thing we tried at the practice yesterday. We asked all the teams to disable the live feeds to see if that helped the communication problems. No change.

I am hoping that the FMS prioritization of packets helps, but given the same problem with close communications (less than 5 feet) and when there were only two bots, I don’t think it was a saturation issue.

It looks like this was it. We disabled QOS management on our router and it appears to be working fine.

What were the video settings that you were sending?

I don’t honestly have a good answer to the question, but I felt it was worth mentioning that My team has had the exact same problems as well. Meaning this isn’t an isolated incident. Could it be the new router configuring software that was given to us this year? Last year’s bridge worked just fine and I configured that manually. This year I used the software and I am having issues. Or am I completely off?