Radio Malfunctioning

Our brand new OM5P-AC radio will not cooperate whatsoever. On the FRC Radio Configuration Utility, we have tried everything that is prescribed in the instructions. We have turned off all adapters, we have power cycled the radio, we have ATTEMPTED to reset it, we have tried to manually set the IP and Subnet mask of the computer to what is advised on the WPlib website, and we have been unable to successfully install firmware or configure the radio. Whenever we attempt to install the firmware, it comes up with the NPF error, and whenever we attempt to configure it, it comes up with the same “disable all adapters, make sure the radio is the only thing connected through ethernet, and reset the radio.” Please help, we have been stuck and our last thought is that this may be a faulty unit.


Above is the error for the firmware installation.

The easiest next thing to try is to use a different PC to try running the radio utility on in case it’s a unique PC quirk.

Are you following these instructions?

Yes, we followed every single instruction and troubleshooting technique on this website, and also tried 2 different computers, three different ethernet cables, and two different power cables.

Have you seen FRC Radio Configuration Application Bug: Error finding NPF device name for adapter (SOLVED)? This is a bit old – also see Can't program Radio with 2020 configuration tool. I’m not claiming there is a current fix here, but if you are comfortable with some of the diagnostic steps cited, possibly worth a shot…

I will try the second route of the first link that you sent, however, the first route did not work for us, as we tried it multiple times. All of the things in the second link we have tried unfortunately.

2 Likes

I’d lean toward uninstalling everything mentioned and then doing a reinstall of the latest version. Other than that, any PC that has not had any of this installed previously is a good route, if available. Good luck!

Will do, thank you!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.