Raspberry Pi FRC Vision Image probelem

I’ve tried to use the image WPI provided on their github page for 2020, but when I boot it up I get a blank screen on the monitor, with a green power light on the pi. I know its not the monitor or the HDMI port because I’ve tested the pi with other OS images, is there something I’m missing here, or does the image WPI provided just not work?

Other people are using it, so the image does work. What version of the Raspberry Pi? Tested versions are 3B and 4. It’s possible you have a corrupted SD card, have you tried to reimage it and verify the image (programs such as Etcher have features to verify after writing).

1 Like

Hmm, I’ve tried two SD cards and they both work with other images, I should mention I’ve been using a Jetson Nano, so that might be it, although I would think that wouldn’t be a problem?

The Jetson Nano is a completely different board. I’ve never tried it, but I would be surprised that a 32-bit Pi image would work on the Nano (maybe a 64-bit image that’s closer to standard Ubuntu might?).

1 Like

Ok, thanks for the help. I’ll just continue working on the vision system we’ve been working on, although the vision image sounds like it could have been really useful.

We looked at doing a Nano image, but after the Pi 4 came out we dropped development. The Nano has CUDA cores, but a slightly slower main processor than the Pi 4, and the vast majority of vision systems don’t take advantage of the CUDA capabilities. There were also initial licensing concerns with redistributing a modified Nano image; these seem to be resolved but it was an additional hiccup in the development process. The bigger barrier is there’s no automated scripting setup that Nvidia provides for building custom Nano images like there is for building custom Pi images.