RaspberryPi Wiring

Wondering how to power a RPi.

I tried taking a micro USB, cutting off the mains end and exposing the 4 cables. I wired the Red and Black to the 5V2A on the Voltage Regulator. I’m leaving the data (white&green) cables alone.

When I try to start the 'bot, the Pi cycle-boots. IE it starts and then spontaneously reboots. I put a monitor on the HDMI port, but its happening so fast, I can’t see the startup messages to know what might be happening.

Anyone seen this? Am I wiring it correctly? Should I punt on the VRM, and just use a USB-uUSB cable for power? Other ideas?

Thanks,
Otto

This sounds like a low voltage/current situation. First thing I would do is check the incoming voltage.

And you are sure you have good software, not a corrupt SD card or anything? Does it work when just using a normal usb to a wall adapter(I would assume so).

A picture would be nice so we can visually see its all wired correctly.

I am assuming you have a good battery, and that the VRM is known to be working.

1 Like

Great questions - I should have mentioned this in my original post.

When I plug the Pi into mains, it works fine. It’s only via the VRM that the problem occurs.

I believe the VRM and Battery to be working, in that the Rio and Radio are both working without problem (admittedly those are the 12V ports, though).

I did put a multimeter on the 5V-2A line, and for voltage, we get 5V. With the help of our EE mentor, we measured the current and see the Pi drawing up to about 300mA and then going back to zero, and back up. Don’t have access to the bot right now, so can’t post a picture.

You’re sure its in the 2A and not the 500mA port?

All raspberry Pi versions recommend more that 700mA

Do you have access to a different VRM you can try testing with?

This sounds like a power supply issue, and I don’t think that is intended behavior for the VRM so I’m wondering if it is faulty.

^and like jimbo said, make sure you are on the 2A port. (I’m liking the threads updating while typing!)

Your VRM isn’t supplying enough current.
What is the voltage level when the Pi is drawing the 300mA?
Do you see a fluctuating voltage when the Pi is in that reboot cycle?

2 Likes

Put a multimeter (or a scope if you have one) on pins 4 and 6 of the Pi’s GPIO while it’s trying to boot. This should tell you quite a lot, especially if:

  1. The voltage drops very low, indicating insufficient current causing the VRM to droop/cut
  2. The voltage stays steady (5v +/- 5%), this indicates some boot-related issue.

Strongly recommend powering from a battery so you can do proper shutdowns and avoid corrupting your SD card. Need something capable of delivering 2+A. Been playing with this one recently with good results:

In case replacing the VRM (as previously suggested) doesn’t work and you’re connected to the 2A port, I’d suggest you take a look at these messages to gather more insight on the problem.

To access the log files of the boot use either Running Headless - checking boot screen messages - Raspberry Pi Stack Exchange or Where is the boot log? [obsolete] - Raspberry Pi Forums

Also, you should make sure it’s not a problem with your wire; once we were stuck for hours figuring out a similar problem until it turned out that it was a problem with the cable. If I remember correctly, for us it was something about the cable being “double-sided” for which you cannot simply strip the wires. (It could just be a wire that was cut in your cable).

Are you re-flashing your SD card every time it fails? because if the pi is reading from the card when it dies it is definitely damaging the card. I would also recommend powering the pi from a battery bank, charging the battery bank from the VRM. as @CEF said, this will allow you to perform a proper shutdown.

1 Like

Chances are it’s only corrupting the card if power is cut during a write operation. @OttoDeLupe’s issue doesn’t seem to be on long enough to get through kernel loading, which should be a read-only step.

Definitely the 2A port

I got hammered with this earlier in the summer. I finally made the SD care read-only (can’t recall the URL with the instructions). Basically, /tmp goes into a ram fs along with a few other files/folders. I also made a backup sd-card in case there’s an issue with the 1st.

Good idea - will pass this along to our EE person.

We always just powered the RasPis on our robots through the GPIO pins on the board instead of the microUSB port. It made swapping power cables easier if needed, because we weren’t relying on custom cables.

We just plugged our RPi 3 into the Roborio USB ports. Originally we tried to power it via the GPIO pins that were connected to the VRM, but that did not supply enough power. I had read that the Roborio could not power the RPi 3 but deiced to try it anyway. It worked really well for us this last year and we never had any problems with corrupted SD cards.