Red power light of death on 3 of 4 Dlinks?

Hey guys,

Over the past few years we have acquired 4 different Dlink units, all of which have worked in the past. However, one by one, they have all stopped working.

We have powered them all the same way, with the 12v-5v converter specified by FIRST, directly from the 5v port of the PDB, from a 30 amp port on the PDB, and from a 12v wall wart adapter. So far, none of these methods have given us any trouble. They have all worked consistently.

It seems that after a while though, our Dlinks decide they don’t want to run any more. We can still access the emergency flash page, and can attempt to update the firmware, but doing so has no affect. They flash blue lights at first, then sit with a red power light until we unplug them.

We have tried a 30/30/30 reset on all of them, and have tried to update the firmware with the emergency page.

Has anybody found a solution for this? I have seen old threads, but no solutions on them.

Thanks for the help,
Ozzy

Looking at your post, if you ran them directly from a 12 volt output, its fried. They are made to run at 5 volt, and will break if you run 12 volts through them. My thought is the 12 volts has fried the memory that holds the firmware. Its possible that the cpu can take 12 volts, or it has its own regulator, but the memory most likely does not, and the 12v will cause that to fail.

There’s the problem. You’re supposed to connect the dc-dc converter to the dedicated 12 volt supply on the bottom of the power distribution board. You can’t connect it to twelve volts from a wall wart supply or from any battery terminal on the power distribution board, regardless of the fuse. Powering it directly from the 5 volt supply is fine, but you’ll just have the radio reset at a higher battery voltage then if you connect it with the 12 volt supply to dc-dc converter.

Ozzy,
It seems like you are using the same voltage convertor for all of the testing. These do go bad and if you are connecting to the same power, that might be the problem. Try using the wall wart power supply on the Dlink and see if that fixes the issue.

You should also be powering the 12v-5v dc-dc converter via the dedicated 12v supply on the PDB, not the 5v port, as per this diagram.